Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Import error: Content type "SysContentFolder" is not allowed to be created under parent of content type "StartPage"


Hey, when trying to import to a fresh EPiServer DB the whole site (start page on), I get the following error:

Content type "SysContentFolder" is not allowed to be created under parent of content type "StartPage"

Anyone has a clue why? I've now enabled All for page availability on start page and the import was successful, but I'm curious why this happens? Could it be because of not having any sites set up in the new site and there was a setting "Use site-specific assets" in the old one?

Nov 24, 2014 11:36


The error is quite "correct" - SysContentFolder is a system content and should not be placed under Start Page - they should both be children of Root. The question is how did you got there.

I assumes that when you export, you chose Root to export instead of StartPage (Home). The starting point should be Start Page.


Nov 24, 2014 12:29

I have the same error.. Any solution?

Dec 09, 2014 17:37

The solution is in the first entry. =)

Your export package contains a SysContentFolder so to add that under the StartPage you need to alow all pages under the StartPage content type.

Dec 09, 2014 18:57

but I do not have any folders on pages like that. But the same scenario. Guess it is happening cause I do not have a site defined yet. As mentioned in the first post. That means that you can not export from start and below i.e. a package containing the start page from another site.

Dec 09, 2014 19:11

SysContentFolder is what is used for the Assets folders in EPi. So it's a default type. If you in the site you exported from checked the "Use site-specific assets" then you will have a Site Assets folder under the StartPage. You can see this if you go to set access rights in admin on the site you exported from.

My guess is that in your StartPage definition you defined what pagetypes are allowed and you didn't define SysContentFolder. So when the import runs it gives you the error. To solve it just go into the StartPage on the Content types and check all during the import.

Guess you could file a bug on it as well.

Dec 09, 2014 19:24

tried that but did not get it to work but I guess you are right. They could also update the UI for exporting the same as for access rights 😊

Dec 09, 2014 19:40

Hi Marija,

Did you ever find a solution to this?  I am seeing the same issue in 2018 :)

Jul 06, 2018 16:48
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.