VPP Migration Tool does not work with latest nuget package of EPiServer.CMS.UI.Core.7.6.0


I am upgrading a site from 7.1 to 7.5 and when I run the VPP migration tool I get this error:

The modules finder couldn't find a directory at '~/EPiServer/Shell'

Parameter name: moduleResourcePath

at EPiServer.Shell.Modules.ModuleFinder.GetModuleInDirectory(String routeBasePath, String moduleResourcePath, IEnumerable`1 configuredAssemblyNames, AutoDiscoveryLevel discoveryMode, String configuredName)
at EPiServer.Shell.Modules.ConfigModuleProvider.GetConfiguredModules(ModulesElementCollection configuredModules)
at EPiServer.Shell.Modules.ConfigModuleProvider.GetModules()
at System.Linq.Enumerable.<SelectManyIterator>d__14`2.MoveNext()
at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
at EPiServer.Shell.Modules.ShellModule.MergeDuplicateModules(IEnumerable`1 modules)
at EPiServer.Shell.ShellInitialization.Initialize(InitializationEngine context)
at EPiServer.Framework.Initialization.ModuleNode.Execute(Action a, String key)
at EPiServer.Framework.Initialization.InitializationEngine.InitializeModules()
at EPiServer.Framework.Initialization.InitializationEngine.Initialize(HostType hostType)
at EPiServer.Framework.Initialization.InitializationModule.Initialize(HostType hostType)
at EPiServer.Framework.Initialization.InitializationModule.FrameworkInitialization(HostType hostType)
at VppMigrationTool.Util.SiteProxy.InitalizeEPiServer(String webConfigPath) in d:\Builds\132\EPiServerCMS Modules\VppMigrationTool\Sources\C\TFS\VppMigrationTool\Util\SiteProxy.cs:line 52
at VppMigrationTool.Util.SiteProxy.Initialize(String destinationPath, String virtualDirectory) in d:\Builds\132\EPiServerCMS Modules\VppMigrationTool\Sources\C\TFS\VppMigrationTool\Util\SiteProxy.cs:line 129
at VppMigrationTool.Util.SiteProxy.Initialize(String destinationPath, String virtualDirectory)
at VppMigrationTool.Converter.get_RuntimeProxyWrapper() in d:\Builds\132\EPiServerCMS Modules\VppMigrationTool\Sources\C\TFS\VppMigrationTool\Converter.cs:line 52
at VppMigrationTool.Converter.FillSiteData() in d:\Builds\132\EPiServerCMS Modules\VppMigrationTool\Sources\C\TFS\VppMigrationTool\Converter.cs:line 101

 I upgraded another site a while ago and that worked fine with the tool. I tried therefor to download the latest version of VPP migration Tool and tried on the site that had work before and it could still connect to the site. After that I updated the nuget packages and tried again with that site and it crashed the same way.

The problem is that in web.config it has added to lines 

<publicModules rootPath="~/modules/" autoDiscovery="Modules" />
<protectedModules rootPath="~/EPiServer/">
<add name="Shell" />   -- THIS LINE
<add name="CMS" />    -- THIS LINE

I tried to remove them and doing that the viewing the site was broken but the vpp migration tool was able to connect to the site.

To tool probably needs to be updated (the version I run was VppMigrationTool_20140107.1


Feb 28, 2014 14:24

I reported a bug, you can probably just create empty folders CMS and Shell under the protected modules path to work around the issue (in a CMS 7 upgraded site that would be whatever <episerver.packaging> is pointing to).

Feb 28, 2014 15:36

Thanks Per

Mar 04, 2014 7:32
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.