Vulnerability in EPiServer.Forms

Try our conversational search powered by Generative AI!

After update the backend cannot find my site




I have been searching internet for a solution, but cannot find a anyone else with the same problem.

I have upgraded an existing site from CMS 6 R2 -> CMS 7, and then CMS 7 -> CMS 7.5.


After minor problems with dll-versions I got the site running.

But when I log into the backend to edit my site, my pages in the tree is not regognized.

It does not even find the recycle bin, just the root element (


If I manual go to an page with a certain page id in the url, the page is displayed but I cannot edit its properties. When I hit the "All properties" button it will load forever. And if i look in the request with developer tools, I see it will return an empty response with 200Ok. 


I browsed the database to find the problem, but no luck!


Anyone having an idea where to start?


Mar 13, 2014 10:36

If you go into admin mode under "Manage Websites", ensure your site is there and has proper SiteUrl and StartPage.

Mar 14, 2014 4:58

I solved it by copy all my stuff to the Demo site, and pointed the connectionstring to my old database.

Now another question:


My new site uses the new feature having the vpp-assets in the database, but I have several images in my vpp-folder.

How can set the website to look in my external vpp-folder as well?


I tried to add virtual folders to my EpiServerFramework.config under virtualPathProviders, but no luck.

Do I have to set anything else in my configs?

Mar 14, 2014 10:18

Never mind. Added locations for my virtual paths in web.config to make it work.

Mar 14, 2014 10:47
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.