Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

Problem with Fallback Language for Blocks

Vote:
 

Hi, 

 

we are just upgrading an EPiServer site for our customer and ran into a problem with fallback language for blocks. It seems blocks do not resect fallback language for the page like for example text fields does. 

 

We have 3 languages in our site. 

 

nb is the main language

nn falls back to nb. 

en falls back to nb. 

 

So I have a page that exists in nb. 

 

On this page there is a rich text field that is culture specific, and a content area that is not culture specific. 

 

I translate the page to en and write a new value for the rich text field in en language. The block is not translated to en. 

 

The page is not translated to nn. When I view the page in edit mode in nn language, it shows the fallback to nb for the page and for the rich text field and for the block. 

 

When I view the page on the web I get a difference that might be a bug: 

 

The nb web page shows as expected with the page, rich text field and block in nb language. 

 

The en web page shows as expected with the page in en and the text field translated to en and the block missing (as it does not exist in en language). 

 

The nn web page is not shown as expected. The page is not translated and should fall back to nb, and so it does. Also the rich text field is shown in nb language, because that is the fallback language on the page. The block is missing though, and it should not be. The page falls back to nb and should be shown just like if nb is the selected language. This is true for text fields, but not for blocks. 

 

It is also strange that when viewed in EPiServer edit more with preview as nn language, the entire page with the text field and the block is shown and in nb language. 

 

I have made a drawing of the situation to try and make it clearer. Is there any way to upload images to this forum? 

 

Thanks for any replies! 

 

#82489
Mar 13, 2014 14:29
Vote:
 

We have the same problem. After upgrading from 7.1 to 7.5, blocks that are not translated do not fall back to the master language (as configured and working before the upgrade).

#84479
Apr 02, 2014 14:33
Vote:
 

A step in the right direction would be to check if you have your language settings (definition of fallbacks) defined on the "Root" page. Our problem was that this was defined on the "Home" page. It is my understanding that blocks only respect language settings defined on Root. 

Hope this helps! 

#84480
Apr 02, 2014 14:37
Vote:
 

Brilliant! Thank you Stian, that solved my problem - you've saved me a lot of time!

#84481
Apr 02, 2014 14:41
Vote:
 

Awesome stuff!

#117167
Feb 12, 2015 14:46
Vote:
 

This is because blocks do not reside under "Home", they reside under a "hidden folder" under Root.

#172527
Dec 06, 2016 11:14
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.