Try our conversational search powered by Generative AI!

Update to CMS 7.5 Problems


I have started a upgrade project on a site from CMS 6 R2 to 7.

Started with a upgrade to CMS 7 and converted pagetypes and migrated out pagetype builder and other stuff that was conflicting.

Got the site to actually run but i have no friendly urls, browsing the root eg. / gets me HTTP Error 403.14 - Forbidden (browsing of directory not enabled). If i browse /Public/Pages/start.aspx i get my startpage.

If i login and go to my CMS Admin i get no preview of my pages (nothing is loaded in the right/middle area for preview). My settings page (pagetype with no template) is displayed correctly in the preview area as the form editing view. Also the root page does this. Navigation to another page after, the preview are is stil showing form editing view from previus working page (page title does update in the top (breadcrumbs).

I have installed CMS framework 7.6.0 with nuget.
In addons section i have the flowing installed:

  • EPiServer 7.5.394 (with nuget in solution 7.6.0 is installed and running on those assemblies).
  • EPiServer Add-on Store Platform 3.0.1845
  • EPiServer Add-on Store UI 3.0.1845
  • EPiServer Edit UI 3.0.1097
  • EPiServer UI Platform 3.0.1209

anyone know how to fix these issues ?

Mar 27, 2014 15:22

Well some progress has been made (i think) with the help of a ongoing support conversation.

The project is now updated to 7.6.3 with nuget and manually removing old packages and manually updating package.config.
However now i cannot run the site att all cuze it gives me the error: Virtual path to protected packages is invalid: ''.

I dont really know why, and the support has not yet goten back to me on this new error.

My web.config looks like this (most omitted):

<?xml version="1.0" encoding="utf-8"?>
<section name="episerver.packaging" type="EPiServer.Packaging.Configuration.EPiServerPackagingSection, EPiServer.Packaging" />

<episerver.packaging protectedVirtualPath="~/STF/Admin/"/>


And as can be seen there is a virtual path provided for protected modules.

Mar 31, 2014 15:52

Hi Mattias,

Did you ever find a solution for this? Ran into the same problem when upgrading today.

Nov 11, 2014 15:34

Hey I also stumbled upon this problem when upgrading a Commerce Manager to Commerce 8.

In order to get rid of the error I had to delete EPiServer.Packaging and EPiServer.Packagin.UI dlls in my bin folder as they were also in my Modules/_protected folder.

Hope that helps someone :)


Nov 26, 2014 0:22

I've experienced this kind of behavior after upgrading to the latest EPiServer nuget packages in Visual Studio while the site was running. In that case the web process were not letting VS update the packages found in /modules/_protected/ because they were in use. Solution was to kill the web process (or temporarily disable IIS).

Nov 26, 2014 8:04

I also seen this, not in upgrading but when deploying with web deploy and then there were because IIS was holding those files. That time I solved it by deploying again.

Nov 26, 2014 9:07
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.