Try our conversational search powered by Generative AI!

Issues with Blob Storage



Having some issues when client has uploaded some images. Some images won't show up except in edit-mode.

This works:


This does not (for some images)


Any ideas? Running CMS Core 7.8.1

Jun 18, 2014 13:04

I world guess it's a access issue

not published or no read access

or it could be that the controller is not registered 

Jun 18, 2014 17:00

I've stumbled upon the same issue, except it seems to be for _every_ image, works in test and dev env, but not in prod for some reason. I've just started digging, I'll post an update when I've located the problem. This site is running

Edited, Jun 24, 2014 15:20

Found the following, the URL in edit mode (working):


The URL in view mode (not working):


The 404 is caused by a missing segment URL, the complete path is supposed to be:


This probably still works in edit mode because the ID is included in the path ",,271"

I got the follwing exception if I added /bilder/ to the path manually:

System.NullReferenceException: Object reference not set to an instance of an object.
   at EPiServer.Core.ContentProvider.GetBySegment(ContentReference parentLink, String urlSegment, ILanguageSelector selector)
   at EPiServer.Web.Routing.Segments.DefaultUrlSegmentRouter.ResolveContentForIncoming(ContentReference contentLink, String urlSegment, SegmentContext segmentContext)
   at EPiServer.Web.Routing.Segments.NodeSegment.GetIncomingNodeInDefaultMode(ContentReference contentLink, SegmentContext context)
   at EPiServer.Web.Routing.Segments.NodeSegment.RouteDataMatch(SegmentContext context)
   at EPiServer.Web.Routing.ContentRoute.MatchSegments(SegmentContext segmentContext)
   at EPiServer.Web.Routing.ContentRoute.RouteSegmentContext(SegmentContext segmentContext)
   at EPiServer.Web.Routing.ContentRoute.GetRouteData(HttpContextBase httpContext)
   at EPiServer.Web.Routing.ContentRouteHelper.SetRouteDataFromRoute(Int32 routeIndex)
   at EPiServer.Web.Routing.ContentRouteHelper.<.ctor>b__2()
   at System.Lazy`1.CreateValue()
   at System.Lazy`1.LazyInitValue()
   at EPiServer.Web.Routing.ContentRouteHelper.get_Content()

Seems to be something fishy with the routing, a simple restart of the application resolved the issue. Must be a bug, but haven't been able to reproduce it.

Jun 24, 2014 15:48

Seems to be fixed in 7.8.1:

Jun 24, 2014 16:21

We are running into something similar, and it seems to be related specifically to whether the user is logged into the CMS or not, rather than whether they are in the admin. 

Image files being served from /globalassets/ work fine in the admin interface, and also in the view mode if the user is logged into the CMS, but if they hit the site as an anonymous user, then images don't load.  Attempting to hit one of the image urls directly results in a redirect to the log in form.

I've checked the access rights, and /globalassets/ inherits from root, such that 'Everyone' has 'Read' access, so I don't know why the login would be required.

Any way to get an anonymous link to the media?  


Jun 24, 2014 16:43

Anonymous access works just fine in my solution, it's supposed to be delivered through /globalassets/.

Jun 24, 2014 16:58

We're getting the same problem for all media assets,  the URL's only work in edit mode when they are prefixed with /UI/CMS/Content/, when outside of edit mode they return a 404. This is for any file type. I have tried removing all access restrictions from the home page and adding 

<location path="contentassets">
<allow users="*" />
<location path="globalassets">
<allow users="*" />

 to the web.config and it still wont work.

We're now using the latest Episerver 8.9, we're using custom membership using Aspnet Identity.

Was this ever solved? Or has anyone got any more troubleshooting ideas?


Jun 26, 2015 17:20

Hi Ben,

I upgraded to the latest Update (72) and i get this behaviour also... The client was complaining about it. 

I opened yesterday a thread about it:

But no replies yet. 

But i'm happy to see that i'm not the only one with this problem. I can recall that prior to this or previous update this used to work without problem. 

This is at the moment a big problem, because every link to assets in all tinyMCE are not working... :-(

Edited, Jul 02, 2015 11:26

I sent the question to support, they had a look through my web.config and noticed that the runAllManagedModulesForAllRequests attribute wasn't added to the modules tag, adding this fixed the problem. Maybe its the same for you?

Simply change:



<modules runAllManagedModulesForAllRequests="true">

Jul 02, 2015 11:43

Awesome Ben,

this did the trick for me also... wondered why i was missing this tag... thanks alot for sharing buddy!!

Jul 02, 2015 11:51
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.