Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Strange internal epi classes in the xhtml editor image function

Vote:
 

Hi,

So I have these strange internal episerver classes in my "edit image" function in the xhtml editor. I have noticed I get similar ones in the regular style dropdown for the xhtml editr as well if I dont have any editor styles at all defined.

I can get my custom classes to sho up at the bottom of the dropdown by ex. making a "img.someclass" in the editor stylesheet, but "EditMenuName" is ignored, and the epi_xxx classes still remain.

Do anyone know of a way to get rid of these and only show my own? Also how do you name the classes in it? The regular "EditMenuName" is ignored here. Screenshot below to clarify (the class "notRounded" is one I added myself):

#87946
Jun 26, 2014 9:53
Vote:
 

So apparently the forum ate my image, my screenshot can be seen here:

http://i.imgur.com/DZlEKHu.png

#87947
Edited, Jun 26, 2014 9:56
Vote:
 

Are you getting any js errors?

#87998
Jun 27, 2014 11:49
Vote:
 

No, no JS errors

#88001
Jun 27, 2014 12:03
Vote:
 

Having the same issue in a 7.1 solution so I gues there is a bug or we are missing something. I never get episerver to remove their properties from the dropdown. 

img.test and .test will result in the same as you described.

#88025
Jun 27, 2014 17:28
Vote:
 

I also get the same namingproblem as you described. The name is Test not the name I set with EditMenuName.

#88026
Jun 27, 2014 17:30
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.