Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

Update-EPiDatabase Error: Found no files to process



I tried to install EPiServer on Azure Websites, following this manual:

After installation of the NuGet Packacke 'EPiServer.Azure' I get the error message, that my database is not updated from 7006.0 to 7011.0 and I should run 'update-epidatabase' from my package manager console.

When I try to run 'update-epidatase' I get the following error:

'No files to process'

I can't find any tips in the manual - so can someone tell me what I am doing wrong?

My setup: Visual Studio Express 2013 for Web and SQL Server 2012 Express using LocalDB.



Aug 27, 2014 13:40

To get scripts use
PM> Export-EPiUpdates 
Run those manualy or add into some installer

Read the last few comments


Edited, Aug 27, 2014 14:13


unfortunalety I get the same error, when I try to run it:

"Found no files to process"

In the exported folders is only one file:


Aug 28, 2014 10:41


Got the same problem but found the cause.

EPis update command scans all packages in the nuget packages folder and searches for tools/epiupdates folders and runs all sql scripts in the tools/epiupdates/sql folder.

In my case we had all packages commited to git but the .gitignore file template that we used had excluded the sql/ folder.

(In my case the EPiServer.CMS.Core.7.13.3\tools\epiupdates\sql was not present)

Removing the restricition in gitignore and restoring the package to get back the sql updates, did the trick...

Edited, Sep 11, 2014 12:53

Running Export-EPiUpdates in nuget console creates a folder called EPiUpdatePackage which contains the SQL scripts to be run. But you don't need to run them manually (and probably shouldn't). You simply run update.bat and it will patch both CMS and Commerce database. To upgrade other environments, simply copy this folder and run update.bat.


Edited, Sep 11, 2014 16:03

I'm experiencing the same "Found no files to process" error message on a server.


Web server with an upgraded project deployed. Database is at version 7006, needs to be at 7007.

Ran Export-EPiUpdates locally and copied the files/folder to the server. 

The exported folder contains a single file: \EPiServer.CMS.Core.7.8.2\epiupdates\config\

Executed update on the server with the path set to the website root.

This results in the "Found to files to process" error.

Appreciate any input! :)

Sep 16, 2014 15:44

Check the  packages\EPiServer.CMS.Core.7.13.3\tools\epiupdates\sql folder (or what version you have).

There should be a 7.8.0.sql script there.

If not, your nuget package is not complete.

Had the same issue where we commited our packages to git and where the .gitignore ignored the sql/ folder.

Sep 16, 2014 16:51

I had this error aswell, likely caused by git, like Dan experienced.

The error occured when using a package through git and depoyment.

When I created a new update package and copied it instead, it worked.

Jan 14, 2015 15:53
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.