Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

EPiServer Backend not working on Azure Websites



I installed EPiServer on Azure Websites, following this manual:

After some problems, the site in running now:

The problem is, that I can't access the backend - no matter what I enter as a user name or password, I always get the same error message:

"Page could not be loaded

The link you specified does not work. This may either be the result of temporary maintenance or an incorrect link."

If you want to try it:

Does anyone has some ideas?


Sep 08, 2014 15:21

You must include modules and modulesbin in the project in visual studio
see more here:

All of EPiServers files are here:


Edited, Sep 08, 2014 15:39

Hi Henrik,

thanks for your reply.

'modules' is included by default and 'modulesbin' is empty - but I will test with 'modulesbin' included.

What about 'obj' and 'bin' ?

Do I need to include them also?


Sep 08, 2014 15:52

No, and you are right, I was thinking wrong. It is all in modules-folder, but include modulesbin also I think

Do not include obj and bin they are recreated every time you build.

Can you verify that the files from modules are in Azure with the ftp you can find in the portal?

Sep 08, 2014 16:38

Did you ever get this issue solved, cause I am having the exact same problem?

I verified that all file from the modules folder is present in azure.

Oct 07, 2014 22:13

Aha of course i found the solution right after, to my problem anyways.

I copied the connectionstring settings from the developers guide here on world:

In this it clears all connection string, and i could see locally that it was missing a connectionstring called AspNetSqlProfileProvider. I removed that and published and backend on azure started working.

Oct 07, 2014 22:25

Hi Paul,

I can't remember what was the solution for exact this problem, but in the end I got everything solved and wrote a german blogpost about the installation process:

If you follow this article - maybe with Google Translator -, your installation will work.

In the near future, I plan to publish an english version of this article :-)

Good Luck,


Edited, Oct 07, 2014 22:29
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.