Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

Upgrade issue from 7.1 to 7.5 - add ons (Google Analytics )

Vote:
 

Hi,

I am facing issues when upgrading episerver project from version 7.1 to 7.5.

I have upgraded initially using the episerver deployment center and then through nuget packages, I updated the version to the latest version which is 7.19

I fixed all errors except there are few warnings but the project compiles successfully. When I run the project I got the following error related

to episerver google analytics. We have episerver google analytic add on installed on version 7.1. 

I have also run the "upgrade/disable Add-ons after product upgrade" but still the same issue as below:-

Does it ring a bell to anyone. Thanks in advance.

The error is :-

Server Error in '/' Application.

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Stack Trace:

[NullReferenceException: Object reference not set to an instance of an object.]
   EPiServer.GoogleAnalytics.Internal.Services.Accessors.GetTrackerSettings(SettingsRepository repository, SiteMappingConfiguration siteMapping) +0
   EPiServer.GoogleAnalytics.Tracking.ScriptBuilder.ShouldAppendScript(HttpContextBase context) +60
   EPiServer.GoogleAnalytics.Tracking.AnalyticsClientResourceRegister.RegisterResources(IRequiredClientResourceList requiredResources, HttpContextBase context, PageData pageData) +79
   System.Collections.Generic.List`1.ForEach(Action`1 action) +14454519
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4627
#121313
May 06, 2015 16:10
Vote:
 

Hi Nazim,

It looks like you still have GA 7.1 binaries in your project? You'll need to update your GA add-on to versions compatible with 7.5 or else you may come across issues with your project.  

#121333
May 06, 2015 18:34
Vote:
 

Thanks Richly, I have tried adding Google Analytics through nuget package version as mentioned below:

EPiServer.GoogleAnalytics      1.6.0.7518

EPiServer.GoogleAnalytics 1.6.0.7518 
EPiServer.GoogleAnalytics 1.7.0.8000 (only valid for version 8 and above) 
EPiServer.GoogleAnalytics 1.7.1.8000 (only valid for version 8 and above)

But still it did not work. I have seen a modeule and modulebin folder under root & modules folder under VPP. Can you confirm do I need to delete both or any of them?

By adding through nuget the 1.6 version, I can see a config file under module->protected. Is this correct? 

Cheers,
Naz

#121335
May 06, 2015 19:30
Vote:
 

You're still in base 7.5 (7.5.394.2) correct? Or have you updated to a more recent version of CMS 7.5? If you're still on base 7.5, then you're expected to see GA add-on folder under vpp/modules folder.  I think you may see some GA dlls in modulesbin folder as well.

#121380
May 07, 2015 18:59
Vote:
 

Thanks for your reply. I have updated it to the 7.19 version and I have updated package from nuget too, but it is still the same. I can see dlls in my modulesbin folder? Do I need to remove them manually?

Cheers,

Naz

#121382
May 08, 2015 9:51
Vote:
 

Yes, please try removing the assemblies in modulesbin.

#121410
May 08, 2015 20:04
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.