Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Anchor tags issue

Vote:
 

I've a problem with the Anchor (bookmark) function in EPiServer.

So, using the TinyMCE editor I've selected a piece of text and pressed the Insert/Edit anchor function, and created a test anchor:

But when pressing the globe icon "Insert/Edit link" it's not being populated in the dropdown:

There are no console errors, no errors in network activity etc..

Anyone else experienced this? Is there a way to perhaps disable anchor tags that may be overriding it? 

#152231
Aug 21, 2016 23:06
Sujit Senapati - Oct 06, 2021 21:54
Please share the version of CMS.
DG
Vote:
 

Hi,

You need to select the text/title on same page where you want this to redirect, then this creation of this link will show an enabled Anchor option. For me it works but initial anchor text/tag doesn't, not sure what is wrong.

Regards

DG

#264623
Oct 06, 2021 12:17
Vote:
 

I was able to test it on CMS 11 and was able to see the same screens as you have posted above. 

Please note, out of the box achors only usable in the same rich text editor as it is created. Within the same RTE you can create and use it as a link. If you are trying to use an anchor created in different RTE, it won't work.

~ Sujit

#264696
Oct 07, 2021 17:14
Vote:
 

@DG / @Sujit this post is from 2016 and the user hasn't been active since then so I doubt this is a still an issue lol

#264767
Oct 08, 2021 10:50
Sujit Senapati - Oct 08, 2021 12:07
Thanks Scott! Looks like DG created a new post along with adding a question on this one which brought it to the top of posts. Thanks for closing it.
DG - Oct 11, 2021 11:35
Yes Scott, you are right :)
@Sujit : Correct, My issue is also resolved, I was doing a mistake in linking, tried it in reverse way and things worked.

Thanks !!
DG
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.