Try our conversational search powered by Generative AI!

Scheduled item problem: "The job identifier cannot be empty"


Have problems with scheduled job plugins not registering correctly after upgrading to EPiServer.CMS.Core version 10.4.2.

The plugin is correctly found in the scan and registered in tblPlugIn, but no entry is made in tblScheduledItem making the UI crasch when trying to access the scheduled job with a "System.ArgumentException: The job identifier cannot be empty."

The plugin registration looks like:

    [ScheduledPlugIn(DisplayName = "Job title", Description = "Job description", SortIndex = 100)]
    public class SomeJob : ScheduledJobBase
        // ...

I've tried to set the GUID argument in the attribute, but without any success. Adding an entry to tblScheduledItem manually solves the issue, but not an ideal solution.

Have I missed something essential in how job registers in later versions? Feedback much appreciated, thanks!

Feb 23, 2017 16:41

What about if you try to rename the job?

Feb 28, 2017 22:29

The renamed job also renders a "System.ArgumentException: The job identifier cannot be empty." when trying to see the job in the UI. Also tried to rollback the database to a version prior to when the job was added, the plugin registers fine in tblPlugIn but not in tblScheduledItem which causes the crasch when trying to view the job in the UI.

Edited, Mar 01, 2017 8:53

As far as I remembered tblScheduledItem record was created once job has started (1st scheduled run).

Just speculating - true to enable by default and sety interval and type directly in attribute. Let it run for the 1st time.

Mar 01, 2017 9:17

I've noticed that the scheduled tasks won't be registrered if the scheduler is disabled. Please ensure it's enabled;

<episerver xmlns="http://EPiServer.Configuration.EPiServerSection">
<applicationSettings enableScheduler="true" ...>


Mar 02, 2017 9:02

Sounds like a bug to me. Manual execution should be possible even when scheduler is disabled.

Mar 02, 2017 10:17

It's definitively a bug. I will report it.

Mar 02, 2017 10:32
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.