Try our conversational search powered by Generative AI!

Issue with CMS 10.8.0 nuget package update for web projects


I'm trying to update a web project in our solution to EPiServer.CMS 10.8.0 from 9.12.2 and get the following error.

Unable to find a version of 'Castle.Core' that is compatible with 'Castle.Windsor 3.4.0 constraint: Castle.Core (>= 3.3.0 && < 4.0.0)', 'EPiServer.CMS.Core 10.8.0 constraint: Castle.Core (>= 3.3.3 && < 4.0.0)'. 0

Here's what I have referenced:

Castle.Core -

Castle.Windsor -

Here's my web.config assembly bindings:

Edited, May 02, 2017 18:34

Hey Todd,

Castle.Core dependency for Episerver.CMS.Core is 3.3.3, see this



May 08, 2017 11:50

Same thing here @Marija. I've installed Episerver 10.8.0, and I have Castle.Core v3.3.3/Castle.Windsor v3.3.0. Hope this helps!


May 08, 2017 19:57

@Marija - I have Castle.Core 3.3.3 installed, but the assembly bindings were telling me 3.3.0.  Nuget says i have 3.3.3 installed.  I tried correcting my assembly bindings but no luck.

I am, however, able to install the EPiServer.CMS.Core to my class libraries.  But, this does not help for my web projects.

My current versions:

CMS - 9.12.2

Commerce - 9.24.1


May 09, 2017 15:53

Hi @Todd,

Have you tried restoring your NuGet packages to see if that resolves the issue? Also, I would make sure that Castle.Core in your packages folder contains a 3.3.3 version. It looks like something is still referencing Castle.Core 3.3.0. From this link here, Episerver.CMS.Core 9.12.2 can use Castle.Windsor v3.3.0 and Castle.Core v3.3.3. Hope this helps!

May 09, 2017 18:17
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.