Try our conversational search powered by Generative AI!

Can't create Alloy project with VS 2017 v15.6.3


When you try to create a new EPiServer-project with Alloy (MVC) you get the error message:

"Could not install package 'EPiServer.CMS.Core 11.3.4'. You are trying to install this package into a project that targets '.NETFramework,Version=v4.5'..."

An empty EPi-project can be created. And it will target .NET 4.6.1. Seems like the Alloy template targets 4.5 still, while the latest packages will target 4.6.1.

I think I was able to do this just a short while ago. Maybe it's connected to the Visual Studio version, which is now 15.6.3

I tried re-installing the EPi VS plugin to ensure I have the latest version of it.

Edited, Mar 20, 2018 15:36

I believe this is a known issue. We probably will release a newer version of the extension soon. 

Mar 20, 2018 15:56

Same problem here... worked before newest version.

Edited, Mar 20, 2018 20:18
<p>Hi, there was issue already earlier and a thread about it:&nbsp;</p>
Mar 20, 2018 21:44

I have the same problem, not able to create an Episerver site in VS2015. I've trid to follow the descriptions here

but I'm having no luck - whatever I do, all options fail.

Mar 21, 2018 9:01

You can download the template from here(Episerver Github)

Edited, Mar 21, 2018 15:34
<p>Great! Thanks!</p>
Mar 22, 2018 7:47
Apr 04, 2018 9:01
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.