Try our conversational search powered by Generative AI!

PageTypeBuilder properties changed in code not updated in CMS


Hi there!

I'm working on a Episerver 6 1r2 site and I'm having trouble with the Episerver Find index.

First of all, one of the page types has a property of type DateTime called "DateToArchive". I'm aware of Find's unability to index DateTime properties due to nullable issues. To solve this I want to change the data type to DateTime?, string, or preferably, delete it all together. I think I've tried eveything right now, I've tried to change the property markup on the page type:

public virtual DateTime? DateToArchive { get; set; }

I've also tried changing it to a string. The changes won't update in the CMS though and the "Match property with PTB" plugin wants me to change it back to DateTime again.

So I've tried updating or changing the property, I'v tried clearing the Find index (which seems to be impossible in Episerver 6 and I think the indexing job maybe clears it before reindexing), I've tried deleting every reference of the property in the DB but I'm not sure if I found the right tables.

Any ideas on how to solve this?

Mar 14, 2018 14:14

What's the [JsonIgnore] doing there?

Mar 20, 2018 23:22

I'm trying to tell Episerver Find NOT to index the property. It still does though.

I'm thinking if Castle Proxies is cached in some way, is there a way of clearing it somehow? That might also solve the problem.

Mar 21, 2018 9:20

Not at all sure about such an old version and find but can you try:

Mar 21, 2018 13:10

If you change the name, does the newly named property work as expected?

Mar 21, 2018 13:31
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.