Try our conversational search powered by Generative AI!

There is already an object named 'netConvertCategoryPropertyForPageType' in the database


After upgrading the following packages:

EPiServer.CMS.Core  11.7.1 -> 11.11.3

EPiServer.CMS.UI.Core  11.4.5 -> 11.19.2              

EPiServer.CMS  11.7.1 -> 11.11.3

EPiServer.CMS.TinyMce 2.2.0 -> 2.8.0

EPiServer.CMS.UI.Sources  11.4.5 -> 11.19.2

EPiServer.Forms  4.11.0 -> 4.24.3                   

EPiServer.GoogleAnalytics   2.1.1 -> 2.2.1

EPiServer.Labs.LanguageManager  3.1.2 -> 3.3.1

EPiServer.Social  2.3.0 -> 3.0.2

BVN.404Handler  11.1.11 -> 11.2.3

Episerver.Framework 11.7.1 -> 11.11.3

And maybe some more as dependencies.

I'm getting: System.Data.SqlClient.SqlException (0x80131904): There is already an object named 'netConvertCategoryPropertyForPageType' in the database.
vid System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapClo

@ dev\packages\EPiServer.Framework.11.10.6\tools\upgrade.psm1:310 char:3     (tested different versions, therefore 11.10.6 here)
when I try to debug the project or update db. 
Anyone stumbled upon this?

May 21, 2019 15:18

I think I had simlar issues before due to the way Episerver handle the versions and updates.

I think I fixed it by just deleting any objects that throw that error or editng the script a commenting out the offending line.

May 22, 2019 11:03


I had to take similar actions.

Firstly it tried to create a stored procedure that already existed so I removed that [netConvertCategoryPropertyForPageType] ,

and then the same on a unique index on TblCategory (IDX_tblCategory_Unique). 

That seems to have solved it for me.

May 22, 2019 15:33
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.