Try our conversational search powered by Generative AI!

ImageProcessor.Web.Episerver not working in production verification slot


I have a website with Episerver 11 where we are implementing the package ImageProcessor.Web.Episerver with the associated package ImageProcessor.Web.Episerver.Azure.

The website is running in Episerver DXP so I have changed the config-files to use the Azure cache. In both integration- och preprod environment everything worked as expected.

But when we started the deployment to production and verified the installation with the slot url before switching it with the production slot we had some problems with most of the images generated with ImageProcessor.Web.Episerver.

Some images were really slow to load, some images were not really done so the bottom of some images had incorrect colors.

In the logs I found a lot of these:
System.Web.HttpException (0x80004005): Server cannot append header after HTTP headers have been sent.
   at System.Web.HttpResponse.AppendHeader(String name, String value)
   at ImageProcessor.Web.HttpModules.ImageProcessingModule.SetHeaders(HttpContext context, String responseType, String[] dependencyPaths, Int32 maxDays, Nullable`1 statusCode)
   at ImageProcessor.Web.HttpModules.ImageProcessingModule.SetHeaders(HttpContext context, Int32 maxDays)
   at ImageProcessor.Web.HttpModules.ImageProcessingModule.PostReleaseRequestState(Object sender, EventArgs e)
   at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.<>c__DisplayClass285_0.b__0()
   at System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step)
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

I have read an article at describing a problem that has this error message:

I have followed every step in that article except step 2, and that is because the slot url is not my primary url. I don't want the website to have the slot url as a primary url, nobody wants. :)

Maybe this problem will be solved if I deploy it into production, I don't know.

Any idea what could be wrong?

Edited, Mar 23, 2023 14:58

Try adding a wildcard hostname binding, if you don't have one already, to see if it resolves the issue.

May 08, 2023 1:31
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.