Try our conversational search powered by Generative AI!

ContentArea property for CatalogContentBase derived types


Is it allowed to use properties of ContentArea type for catalog content classes?


public class CategoryItemContent : NodeContent
   public virtual ContentArea Banners { get; set; }



Actually I've tried and found out following issues:

- "create a new block" link is missed editing catalog content (Commerce -> Catalog), so that is not possible to create blocks for "this category only" like this done for regular (non-commerce) content

Is it limitation or bug?


There are 2 ways you can get catalog content under edit:

1. Commerce -> Catalog -> select content you want to edit (browser url http://hostname/episerver/Commerce/Catalog#context=epi.cms.contentdata:///1073741827__CatalogContent)

2. Open content (i.e. category, product) on user view and press "epi server quick navigator" button (browser url http://hostname/episerver/CMS/#context=epi.cms.contentdata:///1073741827__CatalogContent)

Using first approach you are able only to drag & drop content from "Catalogs" and "Media" gadgets. That it is impossible to add "Blocks" gadget and use content from it (it is absent at Add gadget wizard)

Using second approach "Blocks" gadget is available and you can used shared blocks from it.

Is such context different behaviour normal or it is a bug?


Jan 03, 2014 10:19

Great question, we would also like to use blocks on our product pages as they give a great way to add custom content to differentiate the product pages from each other.

I didn't spot the different behavior across the different edit url's before now but it seems promising :-)

it could be something they want to support but it didn't quite make it in to the final version.


Jan 06, 2014 10:49


I see no reason why a content area should not be allowed to use for catalog content. I think that the reason for the "missing" create new block link is that this functionality requires support for a "local resources" folder which the Commerce catalog content does not currently support.

Regarding the non-existing and non-available blocks gadget as well as the usage in general, I'll forward this to the development team to see what they think going forward. (I'm pretty sure that it should be possible to make the gadget available as well but need to try this out before I give a suggestion on how to do it).

Jan 07, 2014 7:41

Thank you Linus, waiting for response from dev team

Jan 08, 2014 18:28


For your information, we have create two bug reports.

The first is to handle problems with storing the content area for catalog content. (This was not actually a bug and has been closed)

The second is to make it possible to add the blocks gadget when in the Commerce catalog view. (This has been fixed and will hopefully be released quite soon).

Edited, Jan 09, 2014 8:22

Just curious, do you provide public access for your bug tracking system?

Edited, Jan 09, 2014 10:00

The bug for the shared block gadget that is not available is #110583. The bug was tagged as internal and is not currently visible. I have retagged it as public but there is some delay before it's visible in the public bug list.

Jan 09, 2014 10:04

Sorry, for misunderstanding, my question was how can I access bug list? Could you give me the url, please?

Jan 09, 2014 10:18

Check the link in my previous post!

Jan 09, 2014 10:19

Ups, found it, thanks!)

Edited, Jan 09, 2014 10:19

Great! :)

Jan 09, 2014 10:20

Hi, I was wondering if this update was available for us to add Blocks to the Commerce pages?

Many thanks

Jan 17, 2014 9:31

Hi Jonathan!

The update has been done but it hasn't been released yet. I would guess that we might be able to release it withing the next few weeks though. Just to clarify, the update is to make it possible to add the gadget for a user, it will still not be part of the default view when editing Commerce content.

Jan 20, 2014 7:16

Believe it or not, but I just though of some three year old code that was actually added to solve similar scenarios and actually has documentation in the SDK, but that has never been publicly discussed. Add the following section under your <> section in web.config and the blocks gadget should appear for the commerce view (given that you have not customized your view):

<add name="/episerver/commerce/catalog">
<add name="AddSharedBlocks" transformationType="Add"
plugInArea="/episerver/commerce/assets/defaultgroup" />

Jan 20, 2014 10:20

Hi Linus, Thanks this seems to be working - I can now see the Blocks and I can create a new Block too.

Thanks for your help,


Jan 20, 2014 10:30

Just tested it on two separate projects. Works like magic! Thanks!

Jan 20, 2014 13:09

Hello, we still have this issue in Commerce 10.2.3. Do you know the way how to fix it there or some other recommendations?

Edited, Apr 11, 2017 18:39

Hi guys,

Obviously this is an old post but for anyone looking for a solution I wrote the following blog providing a solution to this:


Apr 24, 2018 11:53
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.