Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Script error when upgrading Commerce R3=>7.5

Vote:
 

We keep getting a script error when trying to upgrade to Commerce 7.5, we've upgraded EPiServer to 7.5 and taken the steps specified in the upgrade guide. Following occur:

Could not find a part of the path 'C:\MyWebsite\bin'.
When executing

At C:\Program Files (x86)\EPiServer\CMS\7.5.394.2\Install\Modules\EPiServer Com
merce 7.5.394.2\Install\Upgrade EPiServer Commerce.ps1:292 char:18
+         Remove-EPiFiles <<<<  -DirectoryPath ($targetSiteBin) -Include 'SpellChecke
r.Net.dll;EPiServer.Business.Commerce.UI.dll;EPiServer.Business.Commerce.FindSe
archProvider.dll;Mediachase.ConsoleManager.dll;Mediachase.WebConsoleLib.dll'

We have Everyone access rights to all folders and all assemblies specified above exists in the bin folder.

/J

#87923
Jun 25, 2014 16:25
Vote:
 
#87924
Jun 25, 2014 16:32
Vote:
 

Couldn't find anyting related there? This is the second time we are doing the upgrade (production db now) and we experienced this issue last time as well, that time we had dots in the name on our website folder, when we changed name it solved the issue, unfortunately that didn't help this time.

/J

#87925
Jun 25, 2014 16:37
Vote:
 

Hi,

This is quite strange. The targetSiteBin param should be used some times before it reaches this point. I suggest to rerun on another site to see if the error is consistent. 

Regards.

/Q

#87926
Jun 25, 2014 16:37
Vote:
 

We commented out that line in the upgrade script, and then removed the assemblies manually (which was the part that failed) and now we are getting:

Get-ChildItem : Cannot find path 'C:\projects\SPSM\Source\src\Sites\SPSMArenaWeb\bin' because it does not exist

And the bin path surely exist, with access rights, and we are running deployment center as administrator, so I'm a little bit confused here.

/J

#87927
Jun 25, 2014 17:22
Vote:
 

Would you mind to send me the log files? I can take a look. My email is quma at episerver.com

/Q

#87928
Jun 25, 2014 17:29
Vote:
 

We tried in another environment, and then the issue disappeared.

/J

#87959
Jun 26, 2014 12:36
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.