Try our conversational search powered by Generative AI!

Invalid Processor state when publishing catalog products.



I would like to set up a shared network drive so that I can share a lucence index across multiple servers. I want products to automatically be written to the shared index when they are published from any server by any user. In order to simulate a multiple environment scenario locally, I have done the following

  • Set up a directory on the network e.g. \\sharedDrive\MyIndex\Index
  • Set up a shared database on a remote server
  • Configured both the CMS and Commerce website Search.config to use LucenceProvider and set the storage and the Indexers basePath to reference my shared network drive

With the above configured my plan is to connect from my personal laptop and have a colleague to do the same.

When I ‘Rebuild Index’ from Commerce Manager > Administrator > System Settings > Search Index I can see the index files being built into my shared network drive. However, the issue I am experiencing is that the indexing processor state keeps reverting to ‘invalid’ whenever I publish a product in the catalog. When I select recover it updates my index on the shared drive and says that the state is valid with 0 items in the queue but fails as soon as another product is published in the catalog.

I have searched around the forum and people are suggesting that there may be an issue with the Mediachase.Search.config configurations being different between the CMS and Commerce project. In an attempt to troubleshoot I have also tried to set the appData basePath value in the commerce web.config to my network drive and then referenced [appdata] for the storage and the Indexers basePath in the Mediachase.Search.config. Still no luck.

The product version of commerce (Episerver.Business.Commerce.dll) that I am using is 8.16.1. Also the CMS is using FIND as the search provider but i require an upgrade to use find so attempting to get this to work with Lucene as the search provider.

Related threads & links

Any ideas?



Edited, Dec 13, 2017 12:26

Firstly, that's a very good way to ask question - thumb up on the way you researched, and formatted your question. I wish we have more questions like this.

You're a bit out of luck here, however, my friend. The event-driven indexing (or eventual indexing) is a bit unstable at time and it's really really hard to trouble shoot. I'd suggest you to contact our developer support service because we might need to access to your environment to find the root cause. But at least, can you post the content of your  Mediachase.Search.config files here?

Dec 13, 2017 13:31

Hi Quan,

Thansks for your response :).

Here are screen shots of my Mediachase.Search.config files for both commerce and CMS (iv changed my sharedLocationPath for posting purposes)






For the commerce i have also tried to specify the full path for the storage & basePath as opposed to using [appDataPath]



Dec 13, 2017 14:37

That's pretty correct from what I can tell. Developer support service then :) 

Dec 13, 2017 15:42

Does the CMS lucene index work as expected for you?

If the trouble is only with the Commerce Lucene index you can use the CMS index for Commerce content too.

Dec 13, 2017 15:49

Hi Erik,

The search provider in the main CMS currently uses FIND. I looked at using find for commerce but run into issues and it looked to me as if i needed to upgrade the solution. With this in mind i have been investigating to see whats involved in setting up a shared lucene index hence why i have run into these issues.

@Quan I may have to contact the support team.

Thansk both


Dec 13, 2017 15:53

Ah ok, i thought you replaced find for CMS as well.

Dec 13, 2017 15:55
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.