Try our conversational search powered by Generative AI!

SqlDataProvider.LoadDataSet ignores commandTimeout


Hi Episerver

We are using Episerver Commerce version 10.7.1

Internally in Episerver Commerce, database lookups are made through the Mediachase.Data.Provider.SqlDataProvider class.

It is possible to set the database timeout in web.config like this:

        commandTimeout="3600" />


This configuration seems to be used by most of the methods in the SqlDataProvider, but as far as I can see, the method called LoadDataSet(...) does not apply this commandTimeout setting.

To work around this problem, we have made our own version of the SqlDataProvider that contains this method:

        public override DataResult LoadDataSet(DataCommand command)
            command.CommandTimeout = CommandTimeOut;
            return base.LoadDataSet(command);

But I would like to be able to remove our custom provider in the future :)


Anders Kåre Olsen

Jun 12, 2017 12:08

Hi Anders,

Thank you for your feedback - we will look into this issue.



Jun 12, 2017 15:13

This issue has been fixed in version 10.8.0, released on Jun 30 2017.

Edited, Jul 04, 2017 11:23
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.