Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

Timeout error when importing XML catalog into Commerce (Commerce 13) - Large catalog (+140.000 items)

Vote:
 

We need a bit of help with our import.

Up until today we could import a large catalog (+140.000 items) into Episerver commerce without major problems (besides the time it takes to do it), but suddenly we have started seing SQL errors thrown after a couple of minutes of import. We import using an XML file through the service API.

The error shown is: "One or more errors occurred. [Execution Timeout Expired. The timeout period elapsed prior to completion of the operation or the server is not responding.]"

As far as I could see from some initial Googling it seems to be related to the database, but as we are using the DXC/DXP we don't really have any insights. 

Any tips?

#218763
Mar 20, 2020 6:50
Vote:
 

Episerver support increased our database instance but unfortunately it didn't help. Our import still fails after af few minuts.

I have tried to do the steps indicated in https://vimvq1987.com/episerver-commerce-commandtimeout-configuration/ and it seems to have some effect. Instead of failing after a few minutes, it ran for over an hour, but then failed with another SQL error:

This SqlTransaction has completed; it is no longer usable.

Any tips?

#218764
Mar 20, 2020 6:50
Vote:
 

The command timeout setting should only be used for small number of slow operations. In case of importing big catalog, it's a lot of operations, so increasing the timeout is just delaying the death.

Do you have a ticket number, and is it possible to send your catalog zip file to support for further analysing? 

#218772
Mar 20, 2020 12:00
Vote:
 

Hi Quan Mai.

The ticket ID is #455961 (https://support.episerver.com/hc/en-us/requests/455961). I have just uploaded our catalog to the ticket (I cannot upload it here as it contains customer product data).

After increasing the timeout it actually worked the last time we ran it (took around 80 minutes to import), however if we remove the timeout it fails more or less instantly (after a few minutes).

#218775
Mar 20, 2020 13:36
Vote:
 

Yes that (Sending the catalog to support) is the way it should be, nothing should be posted here.

I had a bit of time to spare, and I looked into that. The catalog does not contains any metaclasses which needed to be imported properly. You will need to provide your content type classes to support - just a head up :) 

#218777
Mar 20, 2020 15:11
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.