ImageVault: unable to see the images when not logged in



We are using ImageVault to store the media. When I am trying to load pages with clear browser - I could not see the image. The link to the image is correct and it seems to be a permissions issue. When I try to access the image directly via link - I have 403 Error.

After the login to ImageVault - the issue dissapears.

Nov 07, 2014 15:51
<p>I have an EPiServer based ASP.Net MVC web-site. There is a page that should search smth by ID. When the search was succcessfull - user should get some info and image. So the image is loaded dynamically. The search service returns some data including Image ID. Images uploaded the image to ImageVault by the ImageVault GUI and have permnent IDs.</p> <p>We are getting the image by some wrappers over ImageVault.Client and then send them to UI.</p> <p>I don't think that the problem is on page because I could not access the Image by direct link. After the first login into ImageVault administrative GUI - evething works just fine. Doesen't metter whether you've been authenticated or not...</p>
Nov 07, 2014 16:26
<p>Hi!</p> <p>Just to clarify, the images won't show for anonymous users? or do they start working if you log in and back out again? have this worked before?</p> <p>Feels a bit like this might be related to internal/public media urls; what does your image-link look like? Unless you set the PublishIdentifier you'll by default get something like /media/ which is internal and won't be accessible for anonymous users. I think the default published image url is something like /publishedmedia/</p> <p>See <a href="">the Internal vs Public media urls section on this IV support page </a></p> <p>//Mathias</p>
Nov 08, 2014 19:46
<p>Hi Mathias!</p> <p></p> <p>Actually it doesn't look like an app permission problem. It doesn't work for <span style="text-decoration: underline;">both anonymous and administrator</span> untill somewone would login into ImageVault. Then after login to ImageVault it will work for any user. Also it would work for you if you just try to acccess the image by the URL within the same browser.</p> <p></p> <p>It is not a media, but a link to a specific image. And this image has an absolute URL that is just used in the HTML.</p>
Nov 09, 2014 11:11
<p>Hi!</p> <p>What does the image vault logs show when you get the 403? hm, do you mean accessing the image in the same browser where someone logged in before or in a different one? </p> <p></p>
Nov 13, 2014 7:35
<p>Hi Mathias!</p> <p></p> <p>I don't have an access to the ImageVault logs.</p> <p></p> <p>I could describe my steps:</p> <ul> <li>I've used FireFox to test the site. It worked fine.</li> <li>I have iE which is used rarely and I never used it to access the site.</li> <li>I've tried to load the page with ImageVault image - but instead of image I have a stub. I've tried to access the image via the direct link - but got 403 error.</li> </ul> <p>As far as I understood it could be an ImageVault issue with timeouts.</p>
Nov 13, 2014 13:52
<p>Hi Boris!</p> <p>Have you been able to resolve this?If not please do register a support case to allow us to investigate this further.</p> <p>BR /Johan Magnusson</p> <p></p>
Nov 27, 2014 10:48
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.