Try our conversational search powered by Generative AI!

PageTypeBuilder error when wrong language selected in Edit Mode


The site I'm working on has sections below the start page that are in different languages (for different countries). There is no translation going on so there is only ever one version of a page as far as language is concerned. When in edit mode, when the language selector (bottom left of screen) is set to English and I click on a page in another language I get an error...

"The current page is not of type CountryHomePage. This often occurs when no id query string parameter is specified."

This site was migrated from EPiServer 4.61 and it worked without PageTypeBuilder so I'm hoping there is a solution.

Strangely, the Url that is displayed in the Edit Mode preview frame is "http://localhost:62222/Templates/Pages/CountryHomePageTemplate.aspx?epslanguage=es&idkeep=True" and there is no id parameter.

Aug 31, 2010 13:49

Hi Jonathan!

The preview frame should have an id parameter so that is the cause of the exception. I have not seen this particular bug myself but we recently did some improvements of page editing which sometimes would cause problems in specific multi-language cases. The case that you are describing should be a fairly usual one so I'm supriced to see it. Which version are you running under now?

Linus Ekström
EPiServer Development Team

Sep 01, 2010 7:15

I've seen this error before but only when I've used the TemplatePage<T> generic class with the wrong page type by accident.

For example, let's say I have "ContentPage" page type which is hooked up to my ContentPage.aspx template page. If the template page inherits from the TemplatePage<StartPage> (the wrong page type class) I'll get the error you've posted.

This may be unrelated to the actual reason behind your issue, but it's the only time I've seen this error.



Sep 06, 2010 17:58

Updating all dependend component and main project to the latest version of Episerver (CMS 6 R2) and Pagetypebuilder (1.3.1) worked for me.

Oct 21, 2011 10:44
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.