Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

I can't see the page tree in the CMS



When I run my site using Windows Authentication, I am able to access the CMS area. However, when I use WS_federation, I have not been able to do it. I was able to access the page by changing the web.config. I can see the page, but the page tree for me to edit pages won't show anything.

Any ideas on what to do?

Oct 05, 2015 22:25

The user that you logon to is it a member to a group that has access to edit/admin? The location path for episerver interface has some default groups. Is it only the pagetree or the complete edit admin? Open firebug and view the console for errors as well. Might get some error when trying to render the edit tree.

Oct 05, 2015 22:36

Yes, the user has access as admin via ws_federation. And only the pagetree seems to be failing. Some other areas may be failing as well, but I can't edit pages so far.

Oct 06, 2015 18:37

If you run it with f12, do you get any errors or something like that in the console?

Oct 06, 2015 20:28

Yes, I am seeing errors. It says,

Could not map property ContentGuid - table tblBigTable does not contain any columns that map to DbType.Guid

Oct 06, 2015 21:26

This might be a long shot but how did you create you db? The error could be cause of the fact you do not have all sp in right place. Not sure how you work with Ws Fedaration actually but I found this threads about a issue looking like this:

The version of episerver is cms 6 but it might relate to your issue as well.

Oct 07, 2015 0:04

Consultants initially built the site. They handed the site to me, so I don't know the details of that. Yesterday I did some research and found that the database scripts to update the table haven't been run. I am running into a similar error when running the update-epidatabase command from the Package Manager Console.

Oct 07, 2015 16:00

I had similar problem like you, the page tree was not showing but site was working normaly. I've did what Eric suggested and generated new scripts but htis time with different target and problem was solved.

Edited, Dec 27, 2016 16:45
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.