Try our conversational search powered by Generative AI!

My New properties doesn't show on catalog page.



I have a solution based on Episerver 8.12 and evereything was working fine. from this morning, when I create a new property, it will not show it on my CMS Editor pages, like in my catalog page.

I had a field with [UIHint(UIHint.CatalogEntry)] that worked as a string and I wanted to understand what is going on, then I saw that when I add a field it doesn't show. I cleared my Temp files/ restart IIS and even restart my windows, but still no success. 

I have to add that yestarday, I had to switch between different branches several time... if it could make a problem

Does anyone have an idea?

Apr 07, 2016 14:04


Just guessing here, but it could be because of assembly versions. If the synced content types in the database comes from a version of your assembly that is higher than the current one, any changes will be ignored (I suspect such a version change could happen when switching between branches). The reason for that function is prevent unwanted changes for instance when working with a shared database, or if an old version is accidentally deployed.


Per Gunsarfs

Apr 07, 2016 16:02

Thanks Per :), I was completely lost!  I've never thought that it could be because of the versioning

Edited, Apr 08, 2016 9:15
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.