Hidden Blocks - Basic Form Elements Text

Vote:
 

Hi,

I'm seeing a strange issue in my CMS forms.

We have a good number of forms, and a good number of elements shared across forms (Common elements)

But some fields show as it's located/placed in "For This Form" (Local content) also used in many forms. below is the screenshot for better understanding. 

At the same time the element is not present in the "For This Form" folder, screenshot reference as below.

It's highly confusing !.. or Am I missing something. ?

If any has an idea about this, please help me to figure out the issue..

Thank you,

Hari

#284002
Jul 20, 2022 17:35
Vote:
 

Hi Hari,

I have replicated this behaviour by moving a form element into a shared folder, then adding the element onto multiple forms, and then moving the element back into the 'For This Form' folder. The result is that the element is reused across multiple forms but it is actually located in the 'For This Form' folder of only one of the forms. The content of that folder changes depending on which form you are currently editing. In order to find your 'E-mail address' element you will have to iterate and go into every form that the element is being used in and inspect the 'For This Form' folder.

Hope this makes sense 😄

p.s. I think it's strange that the CMS allows you to move a form element into a form specific folder after it is already being reused across multiple forms. 

#284040
Edited, Jul 20, 2022 23:48
Harinarayanan - Jul 21, 2022 17:04
Hello Ynze Nunnink... Thank you for the clarifications... You have saved my day. That's True.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.