login problems for regular user after upgrading

after upgrade from episerver 4.41 to 4.61. Normal user account with read access to pages cant login. I have custome login code which works without any problems. user gets authenticated and do have UnifiedPricipal set from login page. but problem appear when user is redirected from login page to portal page after authentication. it seems like all http context is cleared after redirect and user is not reconized as authenticated anymore. And therefor gets redirected to ordinary episerver login page instead of portal page. i also tried to redirect to a simple page which only outputs EPiServer.Security.UnifiedPrincipal.Current property, and it returned AnonymousUser. I compared access right on all pages against the old episerver and its exactly the same. i also tried to give "everyone" user group full access right to all pages but it didnt help. Im using a webservice for authentication which is still on old episerver platform on different machine, but this webservice is only used to authenticate user from login page. And since i do get autheticated on login page, i dont think this have anything to say. Im totaly stucked, can anyone plzz help me solve this (PIIIIIPP) problem. We do not have multi spiserver enviroment in our office, episerver is installed on one local machine with local sql server. NB ! Everything works fine on my old episerver 4.41
Mar 09, 2007 11:23
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.