Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Xform convert problem


I just don't get it...

I need to convert old Forms to Xforms for migrating. First I sure did a mistake. I just used "Convert Form" in admin mode and changed page property type from "Form" to "XForms form". All data were gone.

Then I searched this Forum and bloggs and found Fredrik Haglund's blogg and FAQ Converting old forms to xforms and tried to follow the advices. No luck.

Here is what i've done:

1. Used "Convert Form" to convert form to Xform. I just wonder why the old forms stay on the left side after convert? It would have been easier if the old ones were on the left and the converted on the right.

2. Opened the formpage at admin/page types and added a property MainXForm (type = XForms form) and changed settings so that File Name = "/templates/xform.aspx" instead of "/templates/form.aspx".

3. Opened the formpage at editmode. Now I saw two forms, first one was the old one, the second one empty new one.

4. When I tried to choose the right form from the list, I noticed that any form I clicked, I got the message: "the form is not used on any page". But anyway I chose the right one.

5. When I published the page, there were still one form and one xform. Form had all the data, xform didn't.

6. I deleted the property MainForm so there were left just MainXForm. And when I got back to edit, the data was gone.

I tried also later to delete the MainForm property at the same time as I created the new MainXForm property. Same. Data gone.

What can I do? The site should be in production after a week...

Nov 24, 2008 22:47


I told the client of the problem. He asked: "Why can't we just export the data into excel? We can start with an empty form on the new site?"

Case closed. Cool

But anyway it would have been nice to know what I did wrong...

Nov 25, 2008 15:06
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.