Vulnerability in EPiServer.Forms

Try our conversational search powered by Generative AI!

EPiServer CMS 9.2.1 and FullRefreshPropertiesMetaData



I've upgraded a project to EPiServer CMS 9.2.1 and noticed that Html.FullRefreshPropertiesMetaData doesn't trigger page refresh anymore.

Tried with the latest versions of Chrome and Edge. Also tested on AlloyTech project (upgraded to 9.2.1)

Oct 30, 2015 15:46


We made an upgrade to 9.3.0 and still cannot get FullRefreshPropertiesMetaData to work.

How can we get this listed in ? Do we have to register a new support incident?


Nov 09, 2015 13:26
Nov 11, 2015 15:45

This is fixed in EPiServer.CMS.UI 9.3.3

Nov 27, 2015 14:45


This still doesn't work properly.

Project 1:
- I've created a new Alloy project using Visual Studio Extension.
- Uninstalled EPiServer.CMS and EPiServer.CMS.UI
- Executed Install-Package EPiServer.CMS -Version 9.1.0 and Install-Package EPiServer.CMS.UI -Version 9.1.0

Project 2:
- Created Alloy project
- Upgraded EPiServer.CMS.UI package

I've then opened Model / Pages / StartPage.cs and added the following property:

[Display(GroupName = SystemTabNames.Content)] public virtual PageReference MyReference { get; set; }

I've then opened Views / StartPage / Index.cshtml and added the following code:

@Html.FullRefreshPropertiesMetaData(new[] { "MyReference" }) <div @Html.EditAttributes(x => x.CurrentPage.MyReference)> @if (!ContentReference.IsNullOrEmpty(Model.CurrentPage.MyReference)) { <p>Lorem Ipsum Dolor</p> } </div>

Running project 2:

  • Opened Start page in edit mode, on page edit view
  • I've selected 'Alloy Plan' page for MyReference property

    Expected: The property should display 'Lorem Ipsum Dolor'
    Actual: 'Alloy Plan' is displayed

  • 3. I've clicked somewhere outside MyReference popup window

    Expected: The page should not reload, it was done in step 2
    Actual: Page is refreshed, 'Lorem Ipsum Dolor' is displayed

Screenshot for project 2 (EPIServer.CMS.UI 9.3.3):

Project 1 (EPIServer.CMS.UI 9.1.0) works as expected:

Hope this helps.

Nov 27, 2015 16:51
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.