Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Find 13.2.9 Entry Point Was Not Found Exception

Vote:
 

I updated Find 13.2.9 and was getting a Entry point was not found exception across my site.  I didn't notice any breaking changes in the updated notes, so don't know what could be happening with this.

Here is the stack trace:


[EntryPointNotFoundException: Entry point was not found.]
   EPiServer.Core.Internal.ILazyProperty.get_HasLazyValue() +0
   epi11.Models.Pages.ClerkPage_DynamicProxy.MakeReadOnly() +2440
   EPiServer.Construction.Internal.ContentFactory.CreateContent(ContentType contentType, BuildingContext buildingContext) +352
   EPiServer.DataAccess.Internal.ContentDB.CreateContent(ContentType contentType) +14
   EPiServer.DataAccess.Internal.ContentLoadDB.LoadContentInternal(ContentReference contentLink, Int32 languageBranchId, DbDataReader reader) +288
   EPiServer.DataAccess.Internal.<>c__DisplayClass2_0.<Load>b__0() +289
   EPiServer.Data.Providers.Internal.<>c__DisplayClass31_0`1.<Execute>b__0() +58
   EPiServer.Data.Providers.SqlTransientErrorsRetryPolicy.Execute(Func`1 method) +70
   EPiServer.Core.<>c__DisplayClass121_0.<LoadContentFromCacheOrRepository>b__0() +35
   EPiServer.Framework.Cache.ObjectInstanceCacheExtensions.ReadThroughWithWait(IObjectInstanceCache cache, String cacheKey, Func`1 readValue, Func`2 evictionPolicy) +1035
   EPiServer.Core.Internal.ContentInstanceCache.ReadThrough(ContentReference contentLink, String selectedLanguage, Func`1 readValue) +107
   EPiServer.Core.ContentProvider.LoadContentFromCacheOrRepository(ContentReference contentreference, ILanguageSelector selector) +617
   EPiServer.Core.Internal.ProviderPipelineImplementation.GetItem(ContentProvider provider, ContentReference contentLink, LoaderOptions loaderOptions) +327
   EPiServer.Core.Internal.DefaultContentLoader.TryGet(ContentReference contentLink, LoaderOptions loaderOptions, T& content) +577
   EPiServer.Web.Mvc.Html.UrlResolverExtensions.GetContent(Guid contentGuid, ContentReference contentLink, CultureInfo culture, IContentLoader contentLoader) +270
   EPiServer.Web.Mvc.Html.UrlResolverExtensions.GetShortcutAwareUrl(UrlResolver urlResolver, String internalUrl, RequestContext requestContext, IContentLoader contentLoader, VirtualPathArguments virtualPathArguments, String& linkText) +398
   EPiServer.Web.Mvc.Html.XhtmlStringExtensions.RenderFragment(IStringFragment fragment, HtmlHelper htmlHelper, UrlResolver urlResolver, IContentLoader contentLoader, TextWriter writer, VirtualPathArguments virtualPathArguments) +669
   EPiServer.Web.Mvc.Html.XhtmlStringExtensions.RenderXhtmlStringToWriter(HtmlHelper htmlHelper, XhtmlString xhtmlString, UrlResolver urlResolver, IContentLoader contentLoader, TextWriter writer, VirtualPathArguments virtualPathArguments) +277
   EPiServer.Web.Mvc.Html.XhtmlStringExtensions.RenderXhtmlString(HtmlHelper htmlHelper, XhtmlString xhtmlString, VirtualPathArguments virtualPathArguments) +57
   ASP.util_views_shared_displaytemplates_xhtmlstring_ascx.__Render__control1(HtmlTextWriter __w, Control parameterContainer) in C:\Development\EPI11\epi11\Util\Views\Shared\DisplayTemplates\XhtmlString.ascx:4
   System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +117
   System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +132
   System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +271
   System.Web.Mvc.ViewPage.Render(HtmlTextWriter writer) +75
   System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +132
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +9490
#228279
Sep 22, 2020 17:33
Vote:
 

This seems to have nothing to do with FInd. How is your ClerkPage type defined?

#228314
Sep 23, 2020 7:55
Vote:
 

Same issue here, get the error from first usage of ContentRepository. Updated all Episerver packages today

#228315
Edited, Sep 23, 2020 8:14
Vote:
 

After some digging I found out that the problem was related to specific page types, common for all page types was that we were trying to hide site map settings from Episerver UI like this:

[ScaffoldColumn(false)]
public override string SEOSitemaps { get; set; }

Removing this code made everything work again

#228316
Sep 23, 2020 10:40
Vote:
 

I had one field that was overwritten and I removed it, and got a better issue of the error

The exception is being thrown on simple list of links on the view.  

For example - I'm getting the Entry Point Was Not Found Exception right in the ForEach:

@using EPiServer.Web.Mvc.Html
@using EPiServer.SpecializedProperties

@model LinkItemCollection

@foreach (var o in Model) {
    <li><a href="@Url.ContentUrl(o.Href)">@o.Text</a></li>
}

However, when I move back to 13.2.8 then this eception goes away.  So I assume something in 13.2.8 is conflicting with something in the LinkItemCollection and other Collections.

I'm getting this same exception on another collection of links as well

#228334
Sep 23, 2020 15:44
Vote:
 

This looks like a mismatch of assembly versions.

Older versions of "EPiServer.dll" does not have the "ILazyProperty.HasLazyValue" property shown in your stack trace.

Perhaps you have an older version of "EPiServer.dll" mixed with newer versions of other Episerver assemblies, that try to access this (non-existing) property.

#228338
Sep 23, 2020 21:23
Vote:
 

That could be... I've been keeping up with the updates and my episerver.core is the latest.  I aslo cleared out my .NET cache and did a few clean/rebuilds... and I'm still getting this error.  

the date modified on the EPiServer.dll was Sept 14th, 2020.   Any idea on how else I can make sure I have the right version of the dll?

#228339
Sep 23, 2020 22:33
Vote:
 

I have also just upgraded an Episerver site without seeing this issue.
The versions in my "packages.config" are generally:

EPiServer.CMS.* 11.19.0
EPiServer.CMS.UI.* 11.29.0
EPiServer.Find.* 13.2.9

I suggest you try installing an Alloy demo site (incl. Epi Find) with Episervers VS-plugin.

Upgrade the demo site to latest versions, and then compare it to your own site.
Look for differences in "packages.config" or the "assemblyBinding" section of web.config.

#228365
Sep 24, 2020 6:27
Vote:
 

Make sure you are not using CMS.Core 11.18 which was delisted. You should be using 11.18.1 or 11.19

#228369
Sep 24, 2020 8:38
Vote:
 

I have the same issue as Valina and Kristoffer. Upgraded from 11.13.0 to 11.19 today.
Also tried to upgrade one version at a time. Every version between 11.13.0 and 11.18.1 works, but when I upgrade to 11.19 it failes.

We don't use Find. So it's not that.

EpiServer.CMS.* is 11.19.0

EpiServer.CMS.UI.* is 11.30.0

EpiServer.Framework.* is 11.19.0

The dll's are all the correct versions. Tried clean builds/re-builds, clear cache, deleted temporary ASP.NET files.

-------------------------

Update:

I finally narrowed it down. For me it was one specific property.

I inherited a property with a custom made backingtype (I don't know if the custom part of it has something to do with this or not) which I wanted to hide with [ScaffoldColum(false)] on another page. Prior version 11.19 this works just fine, but now I have to have either have [Ignore] attribute or set the BackingType attribute.

So this works prior 11.19

public class BasePage : PageData {

[BackingType(typeof(MyCustomBackingType))]
[Display(GroupName = SystemTabNames.Content, Order = 1)]
public virtual string MyProperty { get; set; }

}

public class StartPage : BasePage {

[ScaffoldColumn(false)]
public override string MyProperty { get; set; }
}

Now in 11.19 I have to do

public class BasePage : PageData {

[BackingType(typeof(MyCustomBackingType))]
[Display(GroupName = SystemTabNames.Content, Order = 1)]
public virtual string MyProperty { get; set; }

}

public class StartPage : BasePage {

[BackingType(typeof(MyCustomBackingType))]
[ScaffoldColumn(false)]
public override string MyProperty { get; set; }
}

I hope this can help anybody else struggling.

#228553
Edited, Sep 29, 2020 12:35
Vote:
 

This is weird 

I'm using

EpiServer.CMS 11.19.0

EpiServer.CMS.UI 11.30.0 (Just updated this today)

EpiServer.Frameworkd 11.19.0

This works perfectly fine for me .. but when I update EpiServer.Find to 13.2.9 I'm geting the error.  I bring find back and I'm not getting the error

I've also did clean/rebuild and cleared cache and still the updated find is causing issues on my end.

This is what is tripping up on our planetarium site - and there isn't anything with it.   Is there anything I should add to this?

     [Display(
            GroupName = Global.GroupNames.Planetarium,
            Name = "Sub Nav",
            Description = "Links in sub navigation",
            Order = 1010)]
        
        public virtual LinkItemCollection SubNav { get; set; }
#228558
Sep 29, 2020 18:10
Vote:
 

Valina, the links in your LinkItemCollection, they go to other pages with different pagetypes right? If so, have you checked so there isn't something about those properties in those pagetypes that is off? Maybe you have a [JsonIgnore] somewhere on a overridden property that now (with the new Find version) needs some more attributes?

#228586
Sep 30, 2020 11:38
Vote:
 

I dont have any [JsonIgnore] in my project, but I have a few other Json commands

If I add this solution from Mangus Raul's blog post to my web.config, the issue goes away

<add key="episerver:setoption:EPiServer.Core.ContentOptions.ProxyType,EPiServer" value="Castle" />

 So this leads me to beleve that something in the new CMS optimized context proxies are cauing issues in my setup.    While going back to the old proxies is a good backup, it isn't entirely future proof, so I'll need to still play around with it to work fullly.   

I'd like to learn more about the new memory optimized Content proxies, and what I need to do to utalize them withouht breaking my site.  Hopefully some documentation will be provided soon.

#228591
Sep 30, 2020 16:54
Vote:
 

Sorry for the inconvenience.. 

We will look into this asap, I have understood that one case is when overriding a property that has a BackingTypeAttribute. Is this the case for all content models that throws the exception?

#228603
Sep 30, 2020 19:16
Valina Eckley - Oct 05, 2020 15:03
I don't have a BackingTypeAttribute assigned - I'm seeing this on LinkItemCollections.
Vote:
 

Johan, if you register this as a bug please add the number here so we can subscribe in the buglist. Thanks.

#228908
Oct 05, 2020 10:42
Vote:
 

The issue is reported as CMS-16931, a fix is merged into 11.20.0 release that is currently verified by QA so hopefully it will be released soon

#228957
Oct 06, 2020 5:24
Vote:
 

The issue is reported as CMS-16931, a fix is merged into 11.20.0 release that is currently verified by QA so hopefully it will be released soon

#228958
Oct 06, 2020 5:24
Vote:
 

Just FYI both 11.20.0 and 11.20.1 were released. If you are visiting this thread because you have the same issue, please upgrade.

#230496
Nov 06, 2020 15:51
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.