REPLY: automatic indexing of commerce pages (EventedIndexingEnabled / ScheduledPageQueueEnabled) results in wrong document type


This is a reply to existing forum post.
the submit button at the bottom of the page doesn’t work for me, I get an error (IE/Chrome/Firefox)
An invalid form control with name='Body' is not focusable.

so I added a new topic for the reply (sorry) :


namespace EpiWebsite.Models.Commerce

[CatalogContentType(GUID = "69528e40-2926-48df-85ab-....", MetaClassName = "ConfProduct", Description = "Configurable Product", DisplayName = "Configurable Product", GroupName = "")]

public class ConfigurableProduct : ProductContent, IArticle


create a new commerce page of above page type :

then use _contentRepository.Service.Save (newPage)

page is added correctly to catalog, with the correct page type.


EventedIndexingEnabled  is enabled, so this page is automatically added to find index

when I go to find\overview page

I see the new page, but with the wrong page type:


It should look like below, which is what happens when I do a manual  reindex via 'Episerver find content indexing job'  

 Document Types

The index contains 50774 documents mappable to .NET objects. These are of 28 different types.

Type Count

EpiWebsite.Models.Commerce.ConfigurableProduct, EpiWebsite 17272

when EventedIndexingEnabled  is false, then no page is added to the search index (as expected)

Edited, Dec 07, 2018 13:03
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.