Try our conversational search powered by Generative AI!

Episerver.forms multilanguage



I am using episerver.forms and my site has english and dutch languages.

When i submit my form in dutch I always gor the message [Missing text '/episerver/forms/messages/formsubmission/submitsuccess' for 'Dutch'].

I already created EPiServer.Forms_NL.xml in the EmbeddedLangFiles folder. Anyone knows what can be wrong?

Thanks in advance.


Apr 20, 2016 9:17

Did you also change the language node?

<language name="Dutch"

Given that nl is the correct culture to use for Dutch

Apr 21, 2016 0:20

Yes I did

Apr 21, 2016 8:53

Where is your language file located? Does other translations in that file work?

Apr 21, 2016 9:33

The english version is working. My file is exactly in the same folder as the english one created by default ('modules\_protected\EPiServer.Forms\EmbeddedLangFiles') and the name of the file is EPiServer.Forms_NL.xml

Edited, Apr 21, 2016 9:37
<p>And if you add another translation into your Dutch file and wants to use it, for example in a view. Does it work?</p>
Apr 21, 2016 9:38

By the way, I recommend that you keep your changes outside the modules folder for Forms. Can you move your Dutch file to the same folder as your project's other translation XML files?

Apr 21, 2016 9:40

Ok I will do that. Thanks for your answers.

Apr 21, 2016 9:42

I removed EPiServer.Forms_NL.xml and I added the translations to my resource file and now is working fine. Thanks a lot

Apr 21, 2016 13:58

Great that it was solved, don't forget to mark this thread that you found a solution :)

Apr 21, 2016 14:37

Basically, if you have XML file for language translation,  you will put them into the folder where Episerver is told to read them. In case of AlloyMVC, it is \wwwroot\Resources\LanguageFiles

You can also embbed into your DLL, so you don't have to put XML into the above folder.

Default (English) language translation of Forms is embbed in the EPiServer.Forms.dll file.

The XML file you see in wwwroot\modules\_protected\EPiServer.Forms\EmbeddedLangFiles is just a sample (and helper) for you, if you want to translate into another language. It is not the actual language translation Forms use for its UI.

So, if you want , you clone our Forms.En.XML to Forms.NL.XML, translate it, change the id="nl", put it in the  \wwwroot\Resources\LanguageFiles

Good news: Forms will be translated into 12 languages by default (in next release, v2.2). So if you are not hurry, just wait for 1 month.

Apr 25, 2016 12:52

There are still a few keys not present in that language XML, or some values are hard coded.

Also, setting fallbackCulture to anything other than "en" breaks edit mode when using EPiServer Forms.

Apr 26, 2016 10:57

Hi @Stephan, please give me the info, which version you use, which values is hardcoded, I will file the bug to fix it.

I will recheck the fallbackCulture.  Are you mention about this config in episerver.framework.config?

I cannot reproduce it when I switch to sv or fr as fallbackCulture.

Apr 26, 2016 11:31

Yes, that's the config. I should have been more specific, but changing it to something other than "en", and not running CMS in English, causes server errors that break javascript functionality. In my case, changing fallbackCulture to "sv", and setting globalization configuration to use culture "sv-SE" and uiCulture to "sv", causes it.

The texts "Basic Elements" and "Action Elements" doesn't have any corresponding keys in the XML file, so they are still in English after i have translated the XML.

Apr 26, 2016 11:38

Thank you, I will put your info to the bug. fallbackCulture . AFORM-620

"Basic Elements" and "Action Elements" is (ContentTypeAttribute) group name of the ElementBlock. Hmm, with "space charactor" inside. Bug. AFORM-619

Edited, Apr 26, 2016 11:43
<p>Whats the status of this? The bug&nbsp;<span>AFORM-620 is closed and links to an internal jira bug.</span></p>
May 09, 2016 8:25

We found out that the root cause is not in Forms, so AFORM-620 does not solve the root problem (fallback to the non-tranlated language).

This will be fixed in CMS, Bug CMS-3455 Exception loading localization resource when setting fallbackCulture to "sv"

F̶o̶r̶ ̶w̶o̶r̶k̶ ̶a̶r̶o̶u̶n̶d̶ ̶w̶i̶t̶h̶ ̶F̶o̶r̶m̶s̶,̶ ̶p̶l̶e̶a̶s̶e̶ ̶u̶s̶e̶ ̶F̶o̶r̶m̶s̶ ̶2̶.̶1̶,̶ ̶u̶s̶e̶ ̶t̶h̶e̶ ̶S̶v̶.̶x̶m̶l̶ ̶(̶f̶o̶u̶n̶d̶ ̶i̶n̶ ̶\̶w̶w̶w̶r̶o̶o̶t̶\̶m̶o̶d̶u̶l̶e̶s̶_̶p̶r̶o̶t̶e̶c̶t̶e̶d̶\̶E̶P̶i̶S̶e̶r̶v̶e̶r̶.̶F̶o̶r̶m̶s̶\̶E̶m̶b̶e̶d̶d̶e̶d̶L̶a̶n̶g̶F̶i̶l̶e̶s̶)̶,̶ ̶p̶u̶t̶ ̶i̶n̶ ̶y̶o̶u̶r̶ ̶l̶a̶n̶g̶u̶a̶g̶e̶ ̶f̶o̶l̶d̶e̶r̶ ̶(̶w̶i̶t̶h̶ ̶A̶l̶l̶o̶y̶M̶V̶C̶,̶ ̶i̶t̶ ̶i̶s̶ ̶~̶/̶R̶e̶s̶o̶u̶r̶c̶e̶s̶/̶L̶a̶n̶g̶u̶a̶g̶e̶F̶i̶l̶e̶s̶)̶

Edited, May 09, 2016 9:31

The text in that Sv.xml file is in English...

May 09, 2016 9:37

My current installed version of EPiServer.Forms is If I copy the file  \wwwroot\modules_protected\EPiServer.Forms\EmbeddedLangFiles\EPiServer.Forms_SV.xml to my language folder the error occurs, if fallbackculture in web.config is "sv".

May 09, 2016 9:47

Yes Stephan, the sv.xml file is in English. Next month, Forms will be translated to several language.
It is just a work around I suggest at the moment.

May 09, 2016 10:04

This might be the wrong thread to ask in if the bug is in CMS but, what is the status of CMS-3455 ? This currently stops us from updating EPiServer.Forms since it breaks edit mode (not missing translations but exceptions).

Edited, May 09, 2016 12:51
<p>@peter If you set fallbackCulture to "en", things will work, but default to english, if a swedish translation is missing.</p>
May 09, 2016 12:53
<p>@<a href="/System/Users-and-profiles/Community-Profile-Card/?userid=794e9dc0-fe10-e511-9afb-0050568d2da8">Peter Emilsson</a>:</p> <p>&nbsp;<a href="" data-issue-key="CMS-3455">CMS-3455</a>&nbsp;is still in Backlog.</p> <p></p> <p>If</p> <ul> <li>It this is blocking you</li> <li>and you can't wait</li> <li>if you don't mind with some undocumented breaking change</li> </ul> <p>please file a SupportCase, quote my name and this thread into the content. I can introduce a hotfix.</p> <p></p>
May 09, 2016 12:58

@Peter Emilsson:

CMS-3455 is in progress.


  • It this is blocking you
  • and you can't wait
  • if you don't mind with some undocumented breaking change

please file a SupportCase, quote my name and this thread into the content. I can introduce a hotfix from Form side.

May 09, 2016 13:16

@THACH Lockevn:

Whats the status of CMS-3455? Just asking since I cant find it in the public bug list.


May 17, 2016 11:41

CMS-3455 is resolved, will be in EPiServer.CMS.UI 9.7.0

May 30, 2016 3:49
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.