Try our conversational search powered by Generative AI!

EpiBootstrapArea Can't Find Configuration Options


I'm  using EpiBootstrapArea v 4.0.1 with Episerver 10.4.3 in an MVC project and I'm struggling to implement any of the configuration options described in the documentation:

It suggests the AutoAddRow and RowSupportEnabled are false by default but I've got so many rows wrapping my elements they're basically leaving the page. I can't find any references to these settings anywhere in the project. Someone please advise me on how to make this work!

Edited, Jun 13, 2017 1:40


Sorry for hearing trouble. Bootstrap area renderer lib at the moment is not the best from the configuration perspective. I've learned a lot while doing localization provider and will add that goodness to bootstrap renderer as well.

One way to enable these settings is to configure them via IoC container:

context.Container.Configure(container => container
                                        .SetProperty(i => i.RowSupportEnabled = true)
                                        .SetProperty(i => i.AutoAddRow = true));

Meaning that you are readding the same renderer - but this time with properties set to `true`.

Also - the most easiest way to add row support (adding additional row element) would be to pass in view data while rendering the content area:

@Html.PropertyFor(m => m.MainContentArea, new { rowsupport = true})

However, there was an issue in < 4.1 version - row elements were not added if display option was "Automatic" for the blocks inside area.

And also, what eactly you meant by "but I've got so many rows wrapping my elements they're basically leaving the page".

Jun 14, 2017 0:15

Hello! Thank you for the quick response!

To clarify, I know you stated the default setting is RowSupportEnabled and AutoAddRow are false but they seemed to have been set to true in my solution somehow. I had extra rows when I didn't want extra rows.

This solved my issue, explicitly setting them to false removed my extra rows. Thank you!

Jun 14, 2017 1:47

Interesting, default settings are `false`. If you don't have any other setup code - it should be `false` by default. Did you find root cause?

Jun 15, 2017 22:22
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.