Try our conversational search powered by Generative AI!

Silverpop add-on - "Invalid Token" error while trying to connect Episerver to Silverpop



I'm trying to setup Silverpop add-on so I can use it with Episerver Forms. The client provided us the necessary Silverpop settings (pod#=2 and refresh token), but I'm getting an unothorized response back from Silverpop:

"Could not connect to Silverpop. {"error":"invalid_token","error_description":"Invalid refresh token supplied in the request."}"

I've tried 3 different tokens so far, but neither of them worked. The tokens were generated as recommended into the Silverpop documentation:

I've tried a token from another client and that one seems to be working. However it's using pod# version 4. I'm not sure if that makes any difference.

Background information:

EPiServer.MarketingAutomationIntegration.Silverpop = 3.1.0

Episerver CMS  = 10.10.4

Does anyone have any clue why the refresh tokens are not being validated? 

Thank you,


Edited, Aug 14, 2018 11:57

Hi Roxana,

I know it's been 2 years since your post. But is there any chance that you could have resolved this issue.

I have the same, and i have tried a lot of work arrounds without any luck.


Apr 09, 2020 15:29
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.