Try our conversational search powered by Generative AI!

Epi Forms nuget package 4.18 has broken our epi CMS Edit page.


We've loaded epi Forms nuget package in our epi 11 domain and now when we go to to the epi CMS nothing displays. The Edit tab contents are blank.

The only error we see in dev tools is this. "widgets.js:2 OBSOLETE: epi/shell/_StatefulGetterSetterMixin Use dojo/Stateful custom setters/getters instead". Reading another thread, this can't be our issue.

This has left our episerver unuable. Our only solution we can think is is to uninstall the Forms Add-On.

Edited, Nov 14, 2018 15:55

Hi Eric,

Thanks for your information.

Which specific version of epi cms are you using ? Are you able to reproduce on fresh Alloy site ?

Edited, Nov 15, 2018 3:40

We are on epi and Forms 4.18 and .Net Framework of 4.6.1. We have tried to install epi Forms since epi version 9 and still get the same results so have had to uninstall it each time. Now that xForm is offically deprecated and moved to it's own package, we would like to switch to Forms.

Is there a requirements document or checklist we could look at?

I'm not sure loading fresh install of epi would be an apples-to-apples test. I'm sure it will work if we did that.

Edited, Nov 15, 2018 14:50

More information. This is the exact error we are getting but we are on a higher version. This only happens with Forms package installed.

We do not have any custome Add-Ons of our own. Only what is provided in epi.

Our EPiServer.CMS.TinyMce version is v2.6.5

Edited, Nov 15, 2018 16:13

What we found is that epi Forms cannot handle the client adding information to HttpContext.Current.Response after it is made. We append debug information to the page request in our dev doamin.

Nov 29, 2018 16:19
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.