Try our conversational search powered by Generative AI!

Installing Episerver Insight 1.10 does not work for me and strangely breaks the Episerver Find UI


Hi all,

I didn't encounter any of this last year during my first attempt of installing Episerver Insight but I'm seeing a strange issue now with the latest versions of Episerver Insight (1.10.0) in combination with the latest version of the CMS 11.12 (CMS.UI -

Our Epi CMS was recently upgraded by our dev team and everything looks good (I still need to get used to the blue theme :)). I installed Episerver Insight v1.10, following the same steps as per the dev guide. I can confirm the Insight tab now appears which is great. I have also tested the API keys provided to me via Swagger and I can confirm I'm getting a 200 response on one of the GET API's. However, when I click on the actual Insight tab, I get the following error:

Not only is the Insight UI not working, navigating to the Episerver Find UI also now returns the exactly same Socket exception above, which is strange. I tried uninstalling all nuget packages related to Episerver Insight, Profiles and Tracking. Episerver Find comes back up and running again with no issues.

So I tried re-installing the 3 sets of nuget packages to identify the culprit that's causing Episerver Find to break. Up until the installation of Episerver.Profiles.Client and Episerver.Tracking.CMS, the Episerver Find UI works. However, when installing Episerver.Insight.UI, that's when Episerver Find UI gets broken.

I have deployed the codebase to one of the Integration environments in the DXC and the same symptoms occur. Help? 

Oct 05, 2019 16:46

We run Episerver Insight 1.10 in our demo environments which shows some default reporting (which is what the error seems to relate to). Gut feel says perhaps reporting hasn't been enabled on your instance and isn't available? Worth checking in with your CSM to see if reporting is avaialble on your instance?

Edited, Oct 05, 2019 23:45

I see a site with 

EPiServer.CMS.UI 11.21.7
EPiServer.Commerce.UI 13.7.1
EPiServer.Insight.UI 1.11.0
EPiServer.Find.Cms 13.2.4

work normally (on Azure and local). Could you please try with latest version like that?

Oct 08, 2019 4:54

We are trying to reproduce the issue. Please use the following workaround before we have a proper fix:

    public class HackReportingHelper : IReportingHelper, IConfigurableModule
        public bool IsReportingAvailable()
            return true;

        public void ConfigureContainer(ServiceConfigurationContext context)
            context.Services.AddSingleton<IReportingHelper, HackReportingHelper>();

        public void Initialize(InitializationEngine context)

        public void Uninitialize(InitializationEngine context)
Oct 08, 2019 13:27

Thanks Jonas and David. It does seem like the Reporting feature is not available on the account. 

I've implemented the above HackReportingHelper.cs and the Insight UI now displays and Find UI also works as expected. 

However, while I can now load the Insight UI, there are errors in the console and the Insight Profiles tab is infinitely showing the message "Loading..."

The console errors I get on the Profiles tab are:

  1. 500 error on https://MY_DOMAIN_NAME/EPiServer/EPiServer.Insight.UI/profiles/proxy/profilesextensions/_facets/
  2. 500 error on https://MY_DOMAIN_NAME/EPiServer/EPiServer.Insight.UI/profiles/proxy/profiles/?Start=1570539071927&sort(-LastSeen)

Both URL's result to the following:

Similar console errors occur on the Segments tab:

  1. https://MY_DOMAIN_NAME/EPiServer/EPiServer.Insight.UI/profiles/proxy/segments/?filter=!archived%26!favored%26manager%3A!.&Start=1570539271028&sort(-ModifiedDate)
  2. https://MY_DOMAIN_NAME/EPiServer/EPiServer.Insight.UI/profiles/proxy/labels/?sort(+SortOrder)


Oct 08, 2019 14:57

Hi all,

Epi Support found the issue - the Epi Insight APIs require a minimum of TLS version 1.2. Unfortunately the codebase we were working on was not. 

Adding the below to the the Application_Start() in the Global.asax file fixed it:

ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12;
Edited, Oct 17, 2019 5:09
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.