Try our conversational search powered by Generative AI!

Changing language in My settings doesn't work if fallbackLanguage is not set to English


I have taken the Alloy tech project and started from there. When I changed the default language to Swedish, I also changed the fallbackLanguage to Swedish.

It took me a while to figure out why the edit mode sometimes (most of the time) doesn't load in any other language but English. Admin mode works normally, but edit just doesn't load the main part (the upper menu is still there).

I get an error in Chrome: "Cannot read property 'confirmation' of undefined. In FF, I get "_12f2.buttons is undefined".

I have switched back the setting to fallbackLanguage="en", but it either shouldn't be exposed as setting if it's not really changable or it shouldn't crash the edit mode.

Hope this helps someone else.

Jan 25, 2013 10:23

We're having this problem too, any fix for this yet?

Feb 20, 2013 15:13
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.