Try our conversational search powered by Generative AI!

The resource cannot be found. - Requested URL: /Util/login.aspx


Hi guys,

I have a small question.

With my friends, we moved our base lib and some pages, controllers, views, viewmodels to a new Alloy site with Alloy Database and deleted some Alloy things from the web project.

But I think we did something wrong and now our login page can not be found.

In our web.config we have:

<authentication mode="Forms">
<forms name=".EPiServerLogin" loginUrl="Util/login.aspx" timeout="360" defaultUrl="~/" slidingExpiration="true" />


Also, we have in our episerverframework.config

<appData basePath="..\AppDataAlloy" />


Do you have any idea what could be the problem?

Nov 06, 2013 15:53

Could you post your episerverframework.config file? Did you change anything in web.config?


Nov 06, 2013 17:56

Hi Frederik,

thanks for your fast replay (:


No, there isn't any difference between EpiserverFramework.config in the "Alloy" site and in our  "migrated" site. All configs are the same.


Lets explain what we did, because my previous explanation is not very clear :

1) created new alloy with commerce (runs)

2) copy alloy in the same dir and rename it

3) update the site path in IIS from Alloy to the "migrated" site. Change the name of the domain

4) remove all Alloy's controllers, views, models, viewmodels

5) change the assemply's name and namespace

6) add our lib and the old controllers, views, models, ...

7) change the Alloy CMS' database with a fresh CMS database and change the connection string.


except connectionstrings all other config files are the same

Is it possible to be a problem with VPP or other path? Is it problem that now the root dir of the site is renamed?

Nov 07, 2013 9:39

Yes, most likely the problem is the appData path. Is the path correct? You could try explicitly specifying it, example: C:\EPiServer\VPP\AppDataAlloy.


Nov 07, 2013 9:42

On second thought, even if the appData path is wrong, you should still see the util/login.aspx page since this is located under Program Files.

Do you have this in episerverframework.config:

<add virtualPath="~/Util/" physicalPath="C:\Program Files (x86)\EPiServer\CMS\7.0.586.1\application\util"
      name="UtilFiles" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider, EPiServer.Framework" />

And this in web.config:

<location path="util">
      <pages enableEventValidation="true">
          <add tagPrefix="EPiServerUI" namespace="EPiServer.UI.WebControls" assembly="EPiServer.UI" />
          <add tagPrefix="EPiServerScript" namespace="EPiServer.ClientScript.WebControls" assembly="EPiServer" />
      <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
        <clear />
        <add name="AssemblyResourceLoader-Integrated-4.0" path="WebResource.axd" verb="GET,DEBUG" type="System.Web.Handlers.AssemblyResourceLoader" preCondition="integratedMode,runtimeVersionv4.0" />
        <add name="PageHandlerFactory-Integrated-4.0" path="*.aspx" verb="GET,HEAD,POST,DEBUG" type="System.Web.UI.PageHandlerFactory" preCondition="integratedMode,runtimeVersionv4.0" />
        <add name="SimpleHandlerFactory-Integrated-4.0" path="*.ashx" verb="GET,HEAD,POST,DEBUG" type="System.Web.UI.SimpleHandlerFactory" preCondition="integratedMode,runtimeVersionv4.0" />
        <add name="WebServiceHandlerFactory-Integrated-4.0" path="*.asmx" verb="GET,HEAD,POST,DEBUG" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode,runtimeVersionv4.0" />
        <add name="wildcard" path="*" verb="*" type="EPiServer.Web.StaticFileHandler, EPiServer.Framework" />


Nov 07, 2013 9:44

You have probably solved this a long time ago but I ran into the same issue today in a EPiServer 7.5 project. It turned out I was missing the modulesbin folder (with the needed EPiServer dll files).

Apr 29, 2014 15:29

Check if your login.aspx is in this location C:\Program Files (x86)\EPiServer\CMS\6.1.379.0\Application\Util\login.aspx


in this location C:\Program Files\EPiServer\CMS\6.1.379.0\Application\Util\login.aspx.

Wherever it is, make sure your episerver.config is pointed to that location.

That was the issue with me.

Sep 18, 2014 17:24
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.