Try our conversational search powered by Generative AI!

Layout problem with Gadgets


Last week i haven't had time for development in EPiServer since i was writing documentation.
When i finally continued developing i started EPiServer in editmode and saw the following:   (Insert/Edit Link functionality not working in google chrome)

My right pane, normally filled with 'Blocks' and 'Files', now is completely empty.
Instead, 'Blocks' and 'Files' suddenly shows up in the left pane.

When i try to add the 'Blocks' gadget again in the right pane the following javascript error shows up:

Error: Uncaught TypeError: Cannot read property 'id' of undefined.


In our development environment all developers connect to the same EPiServer database.
When i use the development machine of another developer, and log into EPiServer editmode using my Windows login credentials, everything works normally. Therefore i think i can conclude that this issue is somehow related to my local sources.

I know i probably could just reinstall EPiServer CMS and setup a new development environment, but beside the fact that this takes time we would like to know what lead to this issue, if it could happen again and how to solve it.

Any help would be greatly appreciated. Thanks in advance.

Mar 14, 2013 12:16

This has happened to a few people. All I can suggest for now is to reset you're views to default. Clear your cookie and check out the following blog post:

Mar 14, 2013 13:36

Excellent that worked! Many thanks!

However i think something is odd here:
 - Log in on different development machine --> No issues
 - Log in on my development machine --> Issue
   1. Clear cache + Close browser + Restart IIS etc. --> Still an issue (I would expect this would already fix the issue)
   2. Run 'Reset Views' script + Clear cache + Restart IIS etc. --> Fixes the issue

Also, i can't seem to mark this post as ansfered anymore. Can someone do this for me or am i overlooking something?

Mar 14, 2013 15:13

When you cleared the cache did that remove the cookies as well?

I think the icon to mark as answered is probably behind my profile picture ;) It's a small bug with the new world layout which I've reported.

Mar 14, 2013 15:18

Yea that's exactly my point.

On machine x, where no cookies yet existed, it works fine
On machine y, where user cookies exist, i clear the cache including the cookies, and yet it still doesn't work after that

Only after deleting 'user preferences' and clearing cache it works. To me, that's sounds like the user settings are also bound to the machine somehow...

Anyway, it's just a sidenode and since i'm not familiar with EPiServer internals i'm probably forgetting something important ;)

Mar 14, 2013 18:04

Hello everyone,

We have also noticed a few problemen with the layout. Is this reported as a bug and will be fixed in future releases? 

Reset the layout seems like a less good suggestion for our editors but it sure helps for now.

Oct 04, 2013 9:38

We've been encountering this in our 7.5 project. Hitting the reset button on the user profile page resolves it for the time being, but it still reappears. Has this been resolved in one of the later patches or is there a bug id for it? I was unable to find it in the bug list.


// Mathias

Apr 17, 2014 13:52
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.