Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Problem with Import / Export function

Vote:
 

Hi Folk!

I have some strange issues with the export / import feature of EPiServer 7 CMS.

When I export a bunch of pages and import them in another website the page doesn't keep the same numbering even if I have checked "Update existing content items with matching ID"

In other words that mean if a page has an ID of 100 on website "A" when I import the page at website "B" gets an id of 103.

Is there a way to enforce the numbering so that I can keep the id accross sites identical?

Cheers,

Daniel

#67971
Mar 14, 2013 11:14
Vote:
 

I have never had an issue with pages and the ID since I never use the ID of pages. do you have pages on the importing website that already have the IDs you would like to use? Make sure these IDs is available, use a clean db? Not sure you can force the IDs if the numbers are allocated already by other pages.

#68151
Mar 17, 2013 10:01
Vote:
 

It is the guid based identifier that is preserved. The integer based identifier is generated in db and are not guaranteed to be the same across sites (it is very likely that it differs)

Import/export however uses the guid based identifier to locates content (e.g. pages) so in case there already exist a page with a given Guid (which it does if the page has been imported previously in another package) then it will update the page instead of creating new. If you do not select "update existing content items with matching ID" the import will work pretty much as Copy meaning new pages is created each time the package is imported.

#68214
Mar 19, 2013 9:42
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.