Try our conversational search powered by Generative AI!

How to make a EPiServer project go live


Hi anyone can provide some ideas about making the Alloy project go live ? 

I tried to upload the whole project folder to the web server, and trying to open it via the browser. 

But it gave me some error message: 

Server Error in '/' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: An error occurred loading a configuration file: Access to the path 'h:\root\home\xguo22-001\www\\myepiserversite\iux3ujc0.tmp' is denied.

Source Error: 

[No relevant source lines]

Source File: h:\root\home\xguo22-001\www\\myepiserversite\EPiServerFramework.config    Line: 

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.18033


Is something wrong with the EPiServerFramework.config files? 

And I found that the below folders are stored in my local drive:

C:\Program Files (x86)\EPiServer\CMS

C:\Program Files (x86)\EPiServer\CommonFramework

C:\Program Files (x86)\EPiServer\Community

C:\Program Files (x86)\EPiServer\Framework

C:\Program Files (x86)\EPiServer\Mail

C:\Program Files (x86)\EPiServer\Relate

C:\Program Files (x86)\EPiServer\Search

C:\Program Files (x86)\EPiServer\Shared

C:\Program Files (x86)\EPiServer\Sites


So, do I have to upload all of these things to the web server to make the Alloy demo site working?

Any ideas? 


Apr 17, 2013 3:15

That typically occurs if your AppPool user does not have write access to the site root where your config files are.


Apr 17, 2013 8:47

Hi Arild, 

This seems still not working. 

Any other advice?



Apr 18, 2013 8:40

The IIS service account (typically NETWORK SERVICE) needs write permission to your site root. 

Is your AppPool running as NETWORK SERVICE or another user account?

Check this by opening up IIS Manager (Run > "inetmgr"), click ApplicationPools, right-click an application pool and view properties.


Some AppPools use the "ApplicationPoolIdentity". This refers to the built-in account called IIS_IUSR. 

If your application pool uses this account, then you have to give it write access to your site root.

Edited, Apr 18, 2013 8:53


Hi Arild,

I think probably you misunderstand my meaning.

Actually, the project can run properly in my localhost. I mean, if I now type in http://localhost:17000 in browser, the website can show up properly, no proplem at all. 

However, now I bought a web server space from , and uploaded this project to the web server, and trying to make it go live, then it is not working now. 

So if I make any change locally, would it affect the things in server? I don't think so. 

So any comment?

Thanks . 

Apr 18, 2013 9:10

There is nothing wrong in local IIS. It works fine. 

Apr 18, 2013 9:11

Right. That would have been useful to know from the start.

I am not saying that local changes will affect your other web server.

The reason why I'm talking about IIS Manager and access rights is that most EPiServer developers set up live sites from scratch on servers owned by the customer (NOT hosted servers), which means that we usually have to setup all this access stuff ourselves.

Anyway, I still think your problem is related to access rights (on the hosted server, not locally).

When you upload files to your server, do you use FTP or do you have Remote Desktop access to the Windows desktop on the server?




Apr 18, 2013 9:41

Also, looking at your site it seems you are missing some of the files in your BIN folder.

Could not load file or assembly 'System.Web.Mvc, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

Apr 18, 2013 9:48

Ben, you also need to install EPiServer on the web server.

Apr 18, 2013 11:51

Hi Eric, 

Oh! Yes! I have not yet install EPiServer on the web server! 

I did not realize that. How can I install EPiServer on the web server? Can you provide me some reference link or hints? 

Thank you so much!


Apr 18, 2013 12:35

That depends on what your connection to the web server is. Do you have remote desktop access or is it only FTP?

Here are the installation instructions if you have remote desktop access:

Edited, Apr 18, 2013 13:00

Hi Ben, 

Actually I don't have much experience on making a website go live. 

But for this EPiServer one, I just use FileZilla to transfer all the things to the server. So I think it is just the FTP. 

So, any comment? 

Thanks for reply because I am waiting for the solution. :)  

Apr 18, 2013 13:18

As pointed out you need to install EPiServer on the server. For that you need remote desktop access or that someone with access to the server can do it for you.

The files needed for the installation can be found here:

When EPiServer is installed and you have setup an IIS-instance and database, you can use Filezilla to update your site.

Apr 18, 2013 13:26

Frederik Vig has written a getting started with EPiServer development that has a Part 8: Preparing for launch that might help you as well. You can find it here:


Also don't forget to supply the correct License file. This might be a problem if you haven't got access so you can get the ip or mac adress for it. But I assume that you alreday ordered a license file for it.

Apr 18, 2013 13:34

Hi Marcus, 

I am using a free demo license from the EPiServer license center. I think that is still a problem, right?



Apr 18, 2013 13:45

Now I am working on installing EPiServer in the web server. I am not sure that if the server can support it or not. 

Apr 18, 2013 13:46

Demo License is also IP and Mac controlled so if the license you have is for your own desktopthen you will need a new license for the server. 

Also the demo license isn't supposed to be used for live sites. It will of course expire so that you can't have i live for long.

Apr 18, 2013 14:16

Hi Marcus,

It doesn't matter because for now I just want to make it go live for testing purpose. 

The site I want to transfer it to the server is the Alloy sample site. I just want to test it. It is not for actual use at this stage. 

If our company decides to use EPiServer eventually, then we will buy the official license.


Apr 18, 2013 14:45

Ok, then I understand.

Apr 18, 2013 14:46

But the tech staff from the server provider ------,  said that I don't need to install the EPiServer to make the site go live. So confused. 

Apr 18, 2013 16:36

Ben, EPiServer must be installed on the live server because your site depends on some shared components (Windows services for indexing, logging, scheduling, and framework components. Other CMS like Wordpress or Umbraco (which supports) do not need this, but EPiServer does.


Since I don't know which hosting plan you have, I'll just base my answers on the general features overview at



Remember the steps you did to install EPiServer on your local machine? Well, you basically need to repeat them on your live server. 


System requirements for your live web server:

- You need a Windows Server with .NET 4 framework installed. ( seems to offer this).

- You need access to IIS 7 or higher ( seems to offer this, but not all their hosting plans include IIS Manager access).

- You need access to an SQL Server via SQL Management Studio ( seems to offer this).

- Your need to download and install the EPiServer 7 CMS setup package (your user account should have sufficient permissions for this).


Overview of the basic steps to install your site:

- Copy your database from your local machine to on your SQL Server. This requires that you are familiar with SQL Server Management Studio.

- Copy your VPP folders from your local machine to your web server. 

- Copy your website from your local machine to your web server. 

- On the web server, edit your connectionstrings.config file to match the path/username/password to the database you installed on your SQL Server. 

- On the web server, edit your episerver.config file to match the path to the VPP folders you copied, and the path to where you installed EPiServer (usually C:\Program Files(x86)\EPiServer\...)

- On the web server, open IIS Manager and create a new site which points to the website you copied. Use an ApplicationPool that supports .NET 4 and has read/write access to where you copied the website.

-Order a (demo) license from which matches the IP or MAC address on your web server, and put the license in the same folder you copied your website.


If you are stuck on any of these points, I suggest you search this forum or check the Documentation section.

Apr 18, 2013 21:54

Hi Arild, thanks for your very detailed reply. It is very clear now. Thanks again.  

I just get the reply from the technical support team: " According to your detailed info, I do not think it can work on shared host. You may purchase our VPS Plan and you can manually install it with remote desktop access. "

Apr 19, 2013 3:04

Demo License should work fine. 

Here are the system requirements for EPiServer 7.

Apr 19, 2013 7:49

One question: 


Can I just install the demo Alloy site on my server directly (Windows Server 2012)?

I have remote root access privillege for that server.

Can I just do the EPiServer development on that server? 



Apr 22, 2013 4:16

Yes, if you can remotely login to that server, you can do the installation. Have a look at installation instructions:


Apr 22, 2013 11:36


Thanks for reply. 

But after I get everything installed and then http://localhost:17000 open, but the following message shows up:

This webpage is not available

The webpage at http://localhost:17000 might be temporarily down or it may have moved permanently to a new web address.
Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error.
I tried hard to find out what is wrong with this(e.g. configuration, setup, installation , etc.) but I still cannot get it running. 
And it seems there is not much resources about this on google. 
Do you have any idea for this? 
Edited, Apr 22, 2013 15:42

This webpage is not available

The webpage at http://localhost:17000/ might be temporarily down or it may have moved permanently to a new web address.
Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error.
Why did I get the above error message when I try to open Alloy site on the server? 
anyone has seen this before? 
Apr 24, 2013 2:42
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.