Try our conversational search powered by Generative AI!

Installing Alloy demo site in Windows Server 2012


Hi there, 

When I am trying to install EPiServer and the Alloy demo site under Windows Server 2012 VPS, 

after the installation is completed and the http://localhost:17000 is open automactically, the following error message shows up :

(I installed the site under the C:\inetpub\wwwroot , which should be fine)


This webpage is not available

The webpage at http://localhost:17000/ might be temporarily down or it may have moved permanently to a new web address.
Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error.
Does anyone know what is happening? and any solution for this? Urgently. 
Apr 22, 2013 14:31

I believe this is something wrong with the configuration of IIS.

If in IIS Manager I specify the Application pool to .NET v4.5 Classic mode, the web page can be rendered then.

But the images on the page cannot be shown. Still need to fix it.

Apr 23, 2013 3:50
When I change the Application pool to .NETv4.5 Classic pipeline mode then the web page can be rendered now.
But the images on that page still cannot be shown.

Under my own windows 8 PC, when I specify the Application pool to .NETv4.5 Classic pipeline mode the image also cannot be shown, however it works perfect when I specify that to .NETv4.5 Integrated mode. But on my VPS, the images cannot be shown if I specify it to .NETv4.5 Classic pipeline mode(same as under my windows 8 PC), but if I specify that to Intergrated mode, it is even worse,-------> the whole website cannot be shown at all.
I think it is about configuration issue, not about the incorrect path something. 

Do you have any idea about this?

Apr 23, 2013 4:07

Is there any expert who can login to my server to help me get it fixed ?

Apr 23, 2013 7:31

Have you Bing'ed "Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error." on Google? Seems to be problems with proxys, extensions and AVs.

Can also be a problem with compression and/or content length headers.

Apr 23, 2013 13:28

The problem seems to only occur in Chrome too. Have you tried with another browser?

Apr 23, 2013 13:30

Hi Johan,

Yes, I have googled and binged this issue for many times and spent 2 days to try to fix it. 

But nothing works for me. Now I am thing whether I can ring EPiServer to get technical support. 

Or can anyone login to my server to have a look? 

Any EPiServer technical expert is willing to help can Email me to discuss about the login details.

Otherwise I really don't know how to get it fixed.  

Edited, Apr 23, 2013 15:15

There seams to be something wrong with the handlers in general, the resources needed to load the edit-mode isn't working either:

Probably something wrong with the .NET 4 installation. I haven't had any troubles running CMS7 on IIS8.

Apr 23, 2013 21:46

Hi Bjorn,

I didn't have any problem in running CMS7 on IIS8 on my laptop as well. 

But I do have problem running it on the romote server. 

And besides: was notworking because I set it as classic mode.

But now I changed it back to integrated mode, the above link can show you a login page. However once I login, the error which is same as opening http://localhost shows again:

This webpage is not available

The webpage at might be temporarily down or it may have moved permanently to a new web address.
Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error.
Help please. 
Apr 24, 2013 2:13

OH! But amazingly, I can access the edit mode page by http://localhost/MyEPiServerSite

I can enter that mode but when I want to browser the pages inside that mode, same error happens. 

Screenshot can be seen from below link 


Apr 24, 2013 2:58
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.