Try our conversational search powered by Generative AI!

Search function in edit-mode not working


I´m having problems with the search function in EPiServers edit-mode for our site. The search function always says "Content not found" when searching for page id or a page name.

Any ideas what i´m missing?

Apr 24, 2013 16:48

You need to configure EPiServer Search for your site. You can do that from deployment center. 

Apr 28, 2013 20:33

Thanks for your reply. It helped me a bit. Now it´s possible to search for pages with pageId. But it´s not possible to search for page names.

On my AlloyTech site it´s all working, but not on my companys site. The log file says "Update batch could not be sent to service uri ''. Message: 'The remote server returned an error: (404) Not Found.   at System.Net.HttpWebRequest.GetResponse()".

When surfing to it looks ok, and the result is "Endpoint not found."

Does EPiServer CMS Indexing Service need to be installed, or is it an issue with https, or any other idea?

May 03, 2013 10:07

I'm experiencing the same issue. Any ideas on this would be very welcome.

May 06, 2013 15:54

I had the same issue, searching by pageId worked but not by page name.

In my case I was missing WCF configuration in IIS. I had by mistake cleared out the needed handler mappings - adding the .svc mappings fixed the issue.

Surfing on '' should return a "Service - Method not allowed." instead of the 404. Don't know about the https though...

May 08, 2013 18:29

Thank you! After adding the .svc mappings in IIS it´s now possible to search by both page id and page name.

There is still one function that´s not working for us. It´s not possible to search in EpiServers filemanager (asset pane).

On my AlloyTech site it works. For the AlloyTech site the VPP is located on C:/, but for our company site the VPP is located on a fileserver.

Any ideas on that one?

May 13, 2013 15:26

Well, I tried adding a file share VPP to my dev-site. Changed the account running the indexing service to an account which had full access rights to the file share.

Next step was to run a re-index (e.g. Took quite awhile but files on the share started showing up inte filemanager search.

You could use luke to see what's in your current index. Just open the Index-folder from the tool.

That's all I got :)

May 15, 2013 10:58

Hi Daniel,

how(where) did you change the account running the indexing service? Because i have the same problem. All my blob files are located on a file share and i think it needs to have full access rights..

May 31, 2016 13:04


This was a while back, but I'm pretty sure it's the identity setting the application pool is running under. I think I changed this to an account with sufficent access to the file share.

E.g. Specify an Identity for an Application Pool

May 31, 2016 14:38
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.