Try our conversational search powered by Generative AI!

GroupName not getting updated from code


I've used this tool to generate EPi7 page type classes from my database.

The properties' GroupName is set like this:

[Display(Name = "My Property",
Description = "Some description",
Order = 200,
GroupName = "MyCustomGroupName")]
public virtual XhtmlString MyProperty { get; set; }

But for some reason the GroupName seems to be ignored, and the property is shown in the "Content" groupname/tab.

I've tried modifying the group name in the Alloy template, which does work fine.


Any suggestions?

Jul 12, 2013 8:40

Did you install Patch 3? I believe this issue (bug 91301?) was fixed in one of the patches.

Edited, Jul 12, 2013 8:56

Yes, I'm at 7.0.586.16.

If I create a new property on a page type the custom group name for that property is displayed fine.

But when I try changing the group name for an exisiting property (created in CMS6, before the upgrade to 7), the default "Content" tab is always set.

Jul 12, 2013 13:46

If you go to admin mode choose the page type there and the property try clicking reset default and see if that helps.


Jul 12, 2013 14:03

Revert to default works for me, but not when I click it on the page, but on each property.

Jul 12, 2013 14:32

I tried clicking "Revert to default" on the page type settings but it didn't make any difference.



Jul 12, 2013 14:33

That worked for me too. Unfortunately, it would be a lot of work click into each and every property to reset it, so I'm hoping for a better solution.



We managed to reset the property GroupName's by running this SQL query:

update dbo.tblPropertyDefinition set Advanced=NULL


Edited, Jul 12, 2013 14:44

Thank you!

Jul 12, 2013 15:24

I have the same issue tabs going to Content tab and not remaining on their group name, I can edit the property manually ok.  I have tried re sync and also update on tblPropertyDefinition.

I have installed EPiServer 7 - Patch 3 and all add-ons so using 7.1.2

I'm not sure if custom group names strings with spaces cause this issue?  Some enviorments are not effected so it happens ad hoc between updates to a QA or Stage server.

Jul 19, 2013 18:12
Jul 22, 2013 14:16

Hi you guys at EpiServer. We have the same issues. Anyone who can confirm this as a bug, a feature or if there is a fix??

Every night all the properties are set to Content tab. And every morning we manually set them back. It´s NOT ok!

Edit: Our problem was caoused by Epi:s indexing service so it´s now turned off!! Don´t know why it happend...


Edited, Aug 21, 2013 14:39

Hi all,

I agree with Thomas Kalve that it sounds related to 91301 that was fixed in Patch 1.

91301 Property's tab in a strong typed page typed auto change to "Content" after adding any page provider \CMS\Typed Data

We will investigate if this is a regression issue that we missed in patch 2 or 3 or if this is something new. I have reported a new bug for this (#104988) and hope to have a fix for the next patch.

Aug 29, 2013 22:11

@Raymond, @EPiDev

We have been looking at this now without understsanding what causes this behaviour. The only thing we can think of where this will happen involves a multi site scenario sharing the same database where the model is out of sync on one or more of the servers. Is that the case for anyone of you?

If that's not it I recommend that you contact support.

Sep 02, 2013 18:43


The multi-site scenario is partly true based on us having a Local, QA and UAT set up and once code is pushed to each environment it may sometimes affect the tabs.

This does to happen locally when using multiple developers getting source from SVN and then loading the site, they are all sharing the same database.

When we deploy to QA or UAT we manly push the release code as the database does not need updating, the EPiServer initialisation starts and then it may load with the property all in the content tab.

Sep 11, 2013 10:53
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.