Try our conversational search powered by Generative AI!

Site crash on event setup after deploy or recycle of application pool


We are using TCP to set up Eventlistening between two load balanced servers (UDP is not possible in that enviroment) and usually it works fine but when we are deploying updates if we not shut down the site first, or when there are a recycle of the application pool we gets a error on the startup that says like this:

Error creating/opening service host for event replication class

System.ServiceModel.AddressAlreadyInUseException: There is already a listener on IP endpoint This could happen if there is another application already listening on this endpoint or if you have multiple service endpoints in your service host with the same IP endpoint but with incompatible binding configurations. ---> System.Net.Sockets.SocketException: Only one usage of each socket address (protocol/network address/port) is normally permitted
at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.Bind(EndPoint localEP)
at System.ServiceModel.Channels.SocketConnectionListener.Listen()
--- End of inner exception stack trace ---
at System.ServiceModel.Channels.SocketConnectionListener.Listen()
at System.ServiceModel.Channels.ConnectionAcceptor.StartAccepting()
at System.ServiceModel.Channels.ExclusiveTcpTransportManager.OnOpen()
at System.ServiceModel.Channels.TransportManager.Open(TransportChannelListener channelListener)
at System.ServiceModel.Channels.TransportManagerContainer.Open(SelectTransportManagersCallback selectTransportManagerCallback)
at System.ServiceModel.Channels.TcpChannelListener`2.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Dispatcher.ChannelDispatcher.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at EPiServer.Events.EventsInitialization.CreateEventServiceHost()

It goes away after a minute or so but for that minute the site is gone, not working.

We never saw this when we were able to use UDP.

Anyone knows how to do to make this go away?

May 20, 2014 15:42

Hi Henrik,

looks like a process is still use the same TCP port, in your case is 14000. You can restart this process manually, I'd recommend using TCpView tool for finding a process that uses 14000 port or you can restart IIS, if it's possible in your case.

Good luck!

May 20, 2014 22:07

Nikolay. That is true and that process is IIS and EPiServer that are about to close down the connection.

May 21, 2014 8:51

I just found this blog post on the exact same problem, will try it out even if it is for CMS 6 R2

May 21, 2014 9:04

Good to know is that the first solution in the earlier blogg (portSharingEnable) does not work, see this thread:

I have tried the second one (update advanced settings on the application pool and that seems to work great.

I will leave this thread as solved so others with the same problem can follow and know how to fix this

May 21, 2014 10:08


Old post but we hare expeciencing these issues now with an old epi 6 site.

What settings are you refering to here?

"I have tried the second one (update advanced settings on the application pool and that seems to work great."



Jan 12, 2017 14:43

I would assume it is the "Disable Overlapped Recycling" setting as described here:

"To disable overlapped recycling in IIS6 you have to set DisallowOverlappingRotation metabase property to true In IIS7 select the application pool -> Advanced Settings -> Recycling section and set Disable Overlapped Recycling it to true."

Jan 16, 2017 16:43
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.