Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

The file '/link/XXX.aspx' does not exist - error overflows error log.

Vote:
 

I have this site that works on both local machine and test server. The only difference is that on the test server this error is written to the error log once every two seconds. The site uses MVC. .Net 4.5. I had this behavior once before and that time I just deleted all files and copied the files back and it worked. 

System.Web.HttpException (0x80004005): The file '/link/43f936c99b234ea397b261c538ad07c9.aspx' does not exist.
   at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile, Boolean throwIfNotFound, Boolean ensureIsUpToDate)
   at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile, Boolean throwIfNotFound, Boolean ensureIsUpToDate)
   at System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean throwIfNotFound)
   at System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp)
   at System.Web.Routing.PageRouteHandler.GetHttpHandler(RequestContext requestContext)
   at System.Web.Routing.UrlRoutingModule.PostResolveRequestCache(HttpContextBase context)
   at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

The path is the GUID of the root page.
Thanks for any help that leads to a soving of this error!

(Can be a replicate of this error -> http://world.episerver.com/Forum/Developer-forum/EPiServer-7-CMS/Thread-Container/2013/6/TemplateResolver-error/)

#86566
May 23, 2014 16:10
Vote:
 

I have the same error.

#88240
Jul 08, 2014 7:20
Vote:
 

Is a link with that guid link outputted anywhere in the html? My thought was that there is perhaps an img tag on some page that outputs the link (and hence causes the browser to request it).

If that is the case then you could look in the IIS logs to find out which page, it should probably been found immediately before the request with the guid link.

#88994
Aug 05, 2014 15:47
Vote:
 

Hi and thanks for the reply.

I doubt this scenario because this happens with a fresh db without any pages created and before any page at all is visited. If I take a fresh db and then make "iisreset" in cmd it starts directly when restarted.

#89000
Aug 05, 2014 16:20
Vote:
 

I've had this error as well, it was a while ago but I think it was something to do with having no license file. 

#89043
Aug 06, 2014 9:00
Vote:
 

In this case there is a valid licens file. Thanks anyway!

#89044
Aug 06, 2014 9:38
Vote:
 

If it is on the local machine can you use fiddler to record all request and might see all request that is done.
Otherwise I would look into the IIS-logs and try to see what happens just before this request and who is doing the request just as Johan say.


#89047
Aug 06, 2014 10:25
Vote:
 

Henrik Fransas. Thanks! Solved. (Embarrassing of course)

What caused the problem?

Well we have a load balancer that checks for the sites every 5 seconds. But the load balancer goes to the ip-number which was not added to the host names in admin. Once I entered the ip number as a second host address the problem was resolved.

#89048
Aug 06, 2014 10:47
Vote:
 

Glad it was solved!

Probably during routing it could not resolve which site, and hence it fall through the routing unhandled and then ended up in the ordinary Page httpHandler which caused the log entry. I guess another option would be to add a wildcard host '*' instead of the specific ip address (then the problem wont appear again if you move the site to another server...;-) )

#89049
Aug 06, 2014 11:14
Vote:
 

Glad it solved!

#89051
Aug 06, 2014 12:05
Vote:
 

We had the same or a similar sympton with a different cause. Links to a single page type were in the /link/XXX.aspx format.

At first everything was working with two page types with each having it's own template, one page type inheriting from the other. Then I decided to use the same template for both types and removed one template. This produced a template resolving problem which was both evident in the editor's mode when displaying instances of the page but also produced links to the page which where not resolved properly and thus where like /link/XXX.aspx.

The solution was to add "Inherited" to the template class attributes:

[TemplateDescriptor(Path = "~/Templates/Pages/NewsItemPageTemplate.aspx", Inherited = true)]
public partial class NewsItemPageTemplate : BasePageTemplate<NewsItemPageType>
{ [...]

This makes template resolving of inferior classes work correctly, and subsequently solves the URL resolution problem.

#121221
Edited, May 05, 2015 9:18
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.