Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Site not working after moving to VS2013

Vote:
 

I upgraded a VS2008 EPiServer solution to VS2013 without any real trouble (some files could not be backed up).

But when running the application I'm getting "The resource could not be found" error about /default.aspx.

What could be the reason?

#74066
Aug 20, 2013 12:04
Vote:
 

Can you enable logging and look what's there? Is it for just a default.apsx or any requests to the site? Did you upgrade to different IIS version as well?

#74067
Aug 20, 2013 12:43
Vote:
 

check if you have access for the iis user to you files and folders. vs should not do anything specific regarding the project. Also se if you can compile the project, the version of .net so that you have the same in iis as you have in projectfile. you could also try to run aspnet reg iis command for the version you ar running. 

If you are using IIS Express the above should not be needed. Then you should check the logfiles as Vladis told you. Enable log in episerverlog.config in the root of your website. You could also check the windows log and applcation under computer management.

#74069
Aug 20, 2013 13:12
Vote:
 

It's for all requests, all return 404.

VS2008 uses Cassini and VS2013 uses IIS Express. Could that be the cause?

#74072
Aug 20, 2013 13:17
Vote:
 

How do I enable logging in erpiserverlog.config?

Could not find anything in the Windows log.

#74073
Aug 20, 2013 13:22
Vote:
 

Yes that might be the issue...since cassini if i remember correctly has a web.config that is more like a web.config for iis 6 and express use one for iis7. So you could try to install an empty episerver site and copy that web.config to your folder.

 

The log you can enable logging via the config file: http://world.episerver.com/Documentation/Items/Tech-Notes/EPiServer-CMS-6/EPiServer-CMS-60/Logging/

Set the warnlevel and also the path were you should store the file.

#74074
Aug 20, 2013 13:29
Vote:
 

As far as the episerverlog.config it seems to be enabled but no files are being written.

I assume there should be a reference to the config file from web.config? I can't find one.

#74077
Aug 20, 2013 13:44
Vote:
 

You can check whether user has permissions to write to directory you configured in logging config file. I would suggest to set logging event to 'All' - just in case. Is file appender uncommented in 'root' section in log config file? Try to host site in IIS (just create new site pointing to directory where web project is, config app pool in integrated mode).

Which .Net Framework you are targeting?

#74078
Aug 20, 2013 13:52
Vote:
 

Nothing wrong with permissions.

File appender looks okay in config file.

Hosting a new site with the same directory results in the same error.

Targeting .NET 3.5.

#74083
Aug 20, 2013 14:28
Vote:
 

Check your log4net version. Should use 1.2.10. So if you host your site in IIS with the same config file, IIS does not complain about any incompatibilities in web.config file? Is your app pool set to "Integrated"?

#74094
Aug 20, 2013 18:57
Vote:
 

Couldn't find log4net in the project so I got the nuget, version 1.2.11.

No, no complains about incompatible web.config file. Not sure where I'd see that complaint though?

App pool is set to Integrated, yes.

#74104
Aug 21, 2013 6:34
Vote:
 

Adding new files to the root and trying to request them doesn't work so I'm guessing it's a server issue?

Maybe going from VS2008 to VS2013 is far too big of a leap?

#74105
Aug 21, 2013 7:20
Vote:
 

It shouldn't be tooo huge leap otherwise there would not be such a progress :)

If you just copy files (.html?) to IIS direcotry and try to request those resulting in error sounds like really some a server problem.

If EPiServer is consuming 1.2.11 lognet version - log files may not be created (known issue). Downgrade to 1.2.10.

If IIS complains about some compatibility issues in config files - that should be directly in on screen when accessing the site.

Another stupid Q: is app pool and site even started in IIS?

#74108
Aug 21, 2013 8:05
Vote:
 

Hey, I'm the one with the stupid Qs. :)

Yes the app pool and site is started. Trying with IIS or IIS Express (through VS debugging) both yield the same result.

Could it be a missing handler or something?

 

#74109
Aug 21, 2013 8:10
Vote:
 

i would copy a web.config from a standard installation to your root of that site. If you have an old web.config it might not start with iis7 or express. just make a standars installation of en empty episerversite and then copy that config.

#74112
Aug 21, 2013 8:50
Vote:
 

Taking another web.config file causes all kinds of other problems.

#74131
Aug 21, 2013 12:38
Vote:
 

Sounds like this is not purely EPiServer issue :) Can you share some of the problems you face?

#74134
Aug 21, 2013 13:12
Vote:
 

If you get other errors changing config at least you have contact with the folder for the site. All kind of errors can be caused by you not having the same sitespecific settings in that web.config file.

As Vladis said, it would be great if you could share some errors.

#74135
Aug 21, 2013 13:20
Vote:
 

I think it's saying I'm missing a handler for the file type?

 

Detailed Error Information:

Module    IIS Web Core
Notification    MapRequestHandler
Handler    Not yet determined
Error Code    0x80070002
Requested URL

   http://localhost:64666/Default.aspx

#74136
Edited, Aug 21, 2013 13:23
Vote:
 

I've been looking at this http://world.episerver.com/Documentation/Items/Tech-Notes/EPiServer-CMS-5/EPiServer-CMS-5-R2/Changes-Between-IIS6-and-IIS7/


And tried it but still no luck. I call it quits now. It's not worth more of anyones time. :)

#74191
Aug 22, 2013 9:56
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.