Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

EPiServer Online Center Incorrect Link




We have migrated a website from CMS 4.6 to CMS 6 R2 Version. The website's edit & admin mode works correctly but while we are navigating to dashboard we get an Incorrect link error. We have tried to install a new website using deployment center & use the same configs for our website & still it didn't help. We can navigate to dashboard if we add /shell to the url of the website. Can anyone help us to slove this problem?


Thanks in advance


Nov 01, 2011 0:28

How are you using the same config files? Are you overwriting the files created by the deployment centre or amending them? If overwriting then try amending them instead, you may be removing some of the shell nodes.

Also, if possible compare the config files to see how they are different. I hope this helps,


Nov 01, 2011 10:29

Actually I have tried both ways & didn't help! I used deploymnet center & create a new website, the dashboard is working, as long as I modify it to have my website's settings, I get incorrectlink page.


Nov 01, 2011 10:44

Hmm, It still sounds like it might be config related. I know this is not very helpful, but have you tried changing the settings gradually until it stops working? This might narrow down which setting is causing the issue?


Nov 01, 2011 10:52

As long as I use the same config on my website I will get the incorrect link for episerver shell. I'm just guessing if there is any security issue related?


Nov 01, 2011 13:52

Check your web.config. It should contain location section for your EPiServer UI path:

<location path="YourEPiServerUIPath">

 section should contain something like this:

    <publicModules rootPath="~/modules/" autoDiscovery="Minimal" />
    <protectedModules rootPath="~/YourEPiServerUIPath/">
      <add name="Shell" />
      <add name="CMS" />

Also please check episerver.config file. Does it contain virtual path provider registration for EPiServer Shell? By default is looks like this:

<add name="EPiServerShell" virtualPath="~/YourEPiServerUIPath/Shell" physicalPath="C:\Program Files (x86)\EPiServer\Framework\\Application\UI" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />


And one more question: do you have additional binding configured for EPiServer UI on your site?

For example public site is available on http://yoursiteurl/, but EPiServer UI url is http://yoursiteurl:secretPort/YourEPiServerUIPath/

Edited, Nov 02, 2011 12:01

As I have mentioned before there is no problem in the config files. I compared it with another blank EPiServer CMS 6 r2 v. There should be somethingelse that it's missing which I couldn't find it till now!

Nov 03, 2011 11:51

Hi Maryam,

Have you resolved this then? If so what was missing?


Nov 03, 2011 12:43

No, I couldn't find the solution yet!


Nov 03, 2011 12:54

Finally we found the solution to this... The old secureadmin folder (which used to be included in the project) was still in the solution, hindering the "real" shell from loading. Note to self: After migration, make sure all old EPiServer-related folders are removed!

Dec 02, 2011 1:14

Thx a lot. Had exactly the same problem

Edited, Sep 05, 2012 12:43
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.