Try our conversational search powered by Generative AI!

ISelectionFactory GetSelectListItems does not have an implementation



We're having some problems with an implementation of ISelectionFactory. We get the following error message on some of our development environments but not on most of them. 

'xx.DeviceIdSelectionFactory' from assembly 'xx', Version=, Culture=neutral, PublicKeyToken=null' does not have an implementation.


To verify that nothing was wrong with our code we borrowed the code from EnumSelectionFactory and that generated the same error. Does anyone have suggestions on how to solve this problem?

Sep 12, 2011 14:24


I think I remember a similar error that was caused by a mismatch of MVC versions. That the class is compiled against one version of MVC, but runs under another. The interface looks like this:

IEnumerable<System.Web.Mvc.SelectListItem> GetSelectListItems(Type property);

If the SelectListItem is from another version of MVC, the interface will not be fulfilled.

Not sure if I'm leading you down the wrong path, but it's on place to look.


Per Gunsarfs
EPiServer Development Team

Sep 12, 2011 16:13

The problem was caused by a version missmatch as you said. The machines that encountered the error had MVC2 and MVC 3 installed. I uninstalled MVC 3 and that solved the problem. I'm sure that there is a much better and simpler solution but it works now so MVC3 will be future nils's problem :)

Thanks for the help!


Sep 13, 2011 11:17
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.